[Archivesspace_Users_Group] Indexed - but still some issues

Tom Hanstra hanstra at nd.edu
Wed Mar 24 11:42:58 EDT 2021

Hmmm. So I finally tracked the issue down to my Java settings. For some
reason, before/during indexing, Java settings of:


worked fine. But, once indexing was complete, those settings were somehow
unusable. Staff connection would not work, searches failed, etc.

But when I crank down the thread size to:


everything goes back to working. There was a server reboot in there as well
as numerous restarts with config.rb changes and that was the only change
that I found could address the issues. Through a number of restarts, there
was nothing in the logs to indicate the issue. Finally got an error that
suggested Java space issues and tried the lower value and things now work
(as far as I've tested at least).

Quite a journey so far...


On Wed, Mar 24, 2021 at 9:54 AM Peter Heiner <ph448 at cam.ac.uk> wrote:

> Tom Hanstra wrote on 2021-03-24 09:25:24:
> > So, I am now further than I've been yet, at least based upon the logs.
> But
> > I still have something not working properly, because when I do a search
> and
> > find output, nothing is coming up when I try to look at the found
> record. I
> > get the error:
> >
> > *We're sorry, but something went wrong.*
> >
> > When I've seen that in other applications, it has been a rails issue. Not
> > sure if that is what is happening here as well.
> This error should have a corresponding event with at least WARNING level in
> the frontend/public log (depending on which gave you the error) that you
> can
> correlate by event time.
> > Also, the "Found In" links for the records come back with:
> >
> > *The record you've tried to access does not exist or may have been
> > removed.The record you've tried to access does not exist or may have been
> > removed.*
> This would point to the fact that your database and index are not in sync.
> Given your struggles with indexing I'm starting to wonder if you're reading
> from the Solr instance you're writing to.
> p
> _______________________________________________
> Archivesspace_Users_Group mailing list
> Archivesspace_Users_Group at lyralists.lyrasis.org
> http://lyralists.lyrasis.org/mailman/listinfo/archivesspace_users_group

*Tom Hanstra*
*Sr. Systems Administrator*
hanstra at nd.edu
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20210324/28d8089d/attachment.html>

More information about the Archivesspace_Users_Group mailing list