[Archivesspace_Users_Group] New Digital Object records importing with incorrect "actuate" and "show" attributes

Bolton Kelly Doub bdoub at usc.edu
Tue Aug 17 14:10:00 EDT 2021

Hi Benn,

Thanks for your response.

I did some more testing with the help of Valerie Addonizio at Atlas and we came to the same conclusion -- that the two URL columns are switched on the current "bulk_import_template.xlsx". After moving the Digital Object URL from the "URL of Linked-out digital object" column (column BL on the current template) to the "URL of thumbnail" column (column BM), the Digital Objects imported with the "onRequest" and "new" attributes (the attributes intended for the "URL of Linked-out digital object" column). The DO links are displaying correctly on our PUI with these settings.

I also tried importing the DOs from the "bulk_import_DO_template.xlsx" (for creating and linking new DOs to existing archival object records) and that template actually worked as expected with the DOs importing with "onRequest" and "new" attributes.

Valerie forwarded this information to ASpace so hopefully the "bulk_import_template.xlsx" will be fixed soon.


Bo Doub
Accessioning Archivist
USC Libraries Technical Services
Doheny Memorial Library, Room B22

From: archivesspace_users_group-bounces at lyralists.lyrasis.org <archivesspace_users_group-bounces at lyralists.lyrasis.org> On Behalf Of Benn Joseph
Sent: Tuesday, August 17, 2021 8:26 AM
To: Archivesspace Users Group <archivesspace_users_group at lyralists.lyrasis.org>
Subject: Re: [Archivesspace_Users_Group] New Digital Object records importing with incorrect "actuate" and "show" attributes

Hi Bo,
We experienced something similar when using the 'bulk_import_DO_template' to add digital object instances to existing archival objects.

In the spreadsheet, the "Linked-to Digital Object URL" indicates it will be set to Actuate=onRequest, Show=new; the "Thumbnail URL" indicates Actuate=onLoad, Show=embed.

When we import the digital objects, these settings are actually switched-the "Linked-to Digital Object URL" indicates Actuate=onLoad, Show=embed and vice-versa. Otherwise the URLs themselves are in the correct locations in the DO instance. As a result, we see those same display issues and problems accessing content.

We've successfully imported DOs with the spreadsheet importer in the past, so this must be something new. But, we don't use it a ton and can't pinpoint when this might have started.

We're also on v2.8.1.


From: archivesspace_users_group-bounces at lyralists.lyrasis.org<mailto:archivesspace_users_group-bounces at lyralists.lyrasis.org> <archivesspace_users_group-bounces at lyralists.lyrasis.org<mailto:archivesspace_users_group-bounces at lyralists.lyrasis.org>> On Behalf Of Bolton Kelly Doub
Sent: Thursday, August 12, 2021 4:11 PM
To: Archivesspace Users Group <archivesspace_users_group at lyralists.lyrasis.org<mailto:archivesspace_users_group at lyralists.lyrasis.org>>
Subject: [Archivesspace_Users_Group] New Digital Object records importing with incorrect "actuate" and "show" attributes

Hi All,

I recently used the bulk_import_template.xlsx<https://urldefense.com/v3/__https:/github.com/archivesspace/archivesspace/tree/master/templates__;!!Dq0X2DkFhyF93HkjWTBQKhk!BuEuuriJZIEUEkEL_hI08oDNBraEfVxbrOjilLQKuX0Ygihe5ebac1fG376hd9MDV0qFw3bO$> to import some new archival objects along with a linked digital object attached to each new archival object. See attached for the spreadsheet that I imported.

The import successfully created the new archival object and digital object records. However, all of the new digital object records were created with the actuate_attribute set to "onLoad" and the show_attribute set to "embed." According to the documentation on the Import Archival Objects from Excel<https://urldefense.com/v3/__https:/archivesspace.atlassian.net/wiki/spaces/ArchivesSpaceUserManual/pages/1173913646/Import*Archival*Objects*from*Excel*or*CSV*File*from*v2.8.1__;KysrKysrKysr!!Dq0X2DkFhyF93HkjWTBQKhk!BuEuuriJZIEUEkEL_hI08oDNBraEfVxbrOjilLQKuX0Ygihe5ebac1fG376hd9MDV7ObW2BF$> Help Center page, these two File Version attributes are supposed to import with values set to "onRequest" and "new" (not "onLoad" and "embed").

Is anyone else experiencing this? I searched Jira for open issues documenting this behavior and I didn't see any. The Digital Objects being set to "onload" and "embed" is causing display issues when viewing these records on our PUI (I can't click on the Digital Object URI and navigate to our Digital Library).

We are currently running ArchivesSpace v2.8.1. Thanks in advance for any help or feedback.


Bo Doub
Accessioning Archivist
USC Libraries Technical Services
University of Southern California
Pronouns: he, him, his
bdoub at usc.edu<mailto:bdoub at usc.edu>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20210817/43e0b28f/attachment.html>

More information about the Archivesspace_Users_Group mailing list