[Archivesspace_Users_Group] Importing EAD3 in v2.2.1

Christine Di Bella christine.dibella at lyrasis.org
Tue May 1 09:09:11 EDT 2018

Hi Margaret and Trevor,

Trevor is correct – we have not yet added an EAD3 importer, and the documentation should be updated to reflect this. Thanks for the reminder, and apologies for the inconvenience.

Depending on timing, the label/explanatory text in the background jobs part of the application should be as well. We do have on the roadmap work on the importers/exporters, including adding one for EAD3, and a contractor who’s current working with us on various related activities. At least some of this work is due for the release that we are aiming to come out at the end of May, so it may be that the functionality is added before the label gets changed.


Christine Di Bella
ArchivesSpace Program Manager
christine.dibella at lyrasis.org<mailto:christine.dibella at lyrasis.org>
800.999.8558 x2905
cdibella13 (Skype)


From: archivesspace_users_group-bounces at lyralists.lyrasis.org <archivesspace_users_group-bounces at lyralists.lyrasis.org> On Behalf Of Trevor Thornton
Sent: Thursday, April 26, 2018 9:00 AM
To: Archivesspace Users Group <archivesspace_users_group at lyralists.lyrasis.org>
Subject: Re: [Archivesspace_Users_Group] Importing EAD3 in v2.2.1

As far as I know, the EAD importer has not been updated to support EAD3, but this isn't mentioned in the documentation, which I assume was written before EAD3 was released and EAD3 export was added to AS.

On Wed, Apr 25, 2018 at 2:54 PM, Huang, Margaret <Margaret.Huang at philamuseum.org<mailto:Margaret.Huang at philamuseum.org>> wrote:
Dear All,

I am writing to see if anyone has tried re-importing EAD3 into ArchivesSpace.

For a project, I am experimenting with adding some very granular data and would like to use EAD3 because of the @localtype attribute.

I exported EAD3 from ArchivesSpace, did some modification, and then tried to import the EAD3 back into ArchivesSpace. While the EAD3 validated outside of ArchivesSpace, I keep receiving the following error message “instances / 0 / sub_container / type_2: container 2 requires both a type and indicator,” despite clearly having both a type and indicator in the EAD3.

Any insights or suggestions would be greatly appreciated!

Thank you in advance for your time,
Marge Huang

Margaret Huang
Digital Archivist

t 215-684-7641
e margaret.huang at philamuseum.org<mailto:margaret.huang at philamuseum.org>

Philadelphia Museum of Art
PO Box 7646, Philadelphia, PA  19101-7646

Archivesspace_Users_Group mailing list
Archivesspace_Users_Group at lyralists.lyrasis.org<mailto:Archivesspace_Users_Group at lyralists.lyrasis.org>

Trevor Thornton
Applications Developer, Digital Library Initiatives
North Carolina State University Libraries
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20180501/b3324f27/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image002.jpg
Type: image/jpeg
Size: 6608 bytes
Desc: image002.jpg
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20180501/b3324f27/attachment.jpg>

More information about the Archivesspace_Users_Group mailing list