[Archivesspace_Users_Group] error saving an Archival Object

Wendler, Robin King robin_wendler at harvard.edu
Thu Feb 2 17:36:30 EST 2017

Thanks, Noah, much appreciated. I can follow up from that. Apologies for not finding the issue in JIRA -- I tried!


From: archivesspace_users_group-bounces at lyralists.lyrasis.org <archivesspace_users_group-bounces at lyralists.lyrasis.org> on behalf of Noah Huffman <noah.huffman at duke.edu>
Sent: Thursday, February 2, 2017 4:37 PM
To: Archivesspace Users Group
Subject: Re: [Archivesspace_Users_Group] error saving an Archival Object


Here's an unresolved JIRA issue describing this problem: https://archivesspace.atlassian.net/browse/AR-1326<https://urldefense.proofpoint.com/v2/url?u=https-3A__archivesspace.atlassian.net_browse_AR-2D1326&d=CwMFAg&c=WO-RGvefibhHBZq3fL85hQ&r=JKUSUWdXrLBGP_rNc_JtcJNO9wvGRzWSZ2uoZzcT59w&m=fgOWxSWuXz7QmRfUg2ooThQwGDM4LH_Nf25X0cMflps&s=U5qNy3vSM3JnoAjrjHnZapxkY0Hz0_nirOPpC8-gMKw&e=>

It tends to happen when you try to edit an archival object record that has been transferred from another resource record.

As far as I know, there are a couple of fixes for this:

1.       Resequence your entire ASpace database.  To do this, shut down ASpace, modify config.rb (#AppConfig[:resequence_on_startup] = True), and restart.  Beware that resequencing a large database will take a long time, but this should prevent the same error from occurring in other records.

2.       Install this plugin that allows you to resequence only the resource record where the error occurs: https://github.com/archivesspace/resync<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_archivesspace_resync&d=CwMFAg&c=WO-RGvefibhHBZq3fL85hQ&r=JKUSUWdXrLBGP_rNc_JtcJNO9wvGRzWSZ2uoZzcT59w&m=fgOWxSWuXz7QmRfUg2ooThQwGDM4LH_Nf25X0cMflps&s=yy1-o5Md6WysLbA5hA4Z3zBI5c_-GMOPGuL1mTjP6bY&e=>


From: archivesspace_users_group-bounces at lyralists.lyrasis.org [mailto:archivesspace_users_group-bounces at lyralists.lyrasis.org] On Behalf Of Wendler, Robin King
Sent: Thursday, February 02, 2017 3:46 PM
To: archivesspace_users_group at lyralists.lyrasis.org
Subject: [Archivesspace_Users_Group] error saving an Archival Object

Hello, ASpacers,

         When saving the archival object below, changed only by adding a single space preceding "Tours" in the title, we get the following error message:

[cid:image001.png at 01D27D70.E6CB7BB0]

The same error usually occurs if we try to change other archival object records attached to this resource record, but not always. One I was able to change, but received the error when I tried to change it back. Another I could change and change back without encountering the error. The resource record itself can be changed.  Any ideas about why this is happening and what we can do to clear it up?

Thanks for your thoughts,


Robin Wendler

Library Technology Services

Harvard University

90 Mt. Auburn St.

Cambridge, MA 02138


r_wendler at harvard.edu<mailto:r_wendler at harvard.edu>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20170202/cf46bebc/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.png
Type: image/png
Size: 116837 bytes
Desc: image001.png
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20170202/cf46bebc/attachment.png>

More information about the Archivesspace_Users_Group mailing list