[Archivesspace_Users_Group] Alternative Way to Delete a Resource

Majewski, Steven Dennis (sdm7g) sdm7g at eservices.virginia.edu
Fri Oct 21 11:52:59 EDT 2016

After import, it may take a while for the new resources to be indexed and show up in resource browse — especially for importing a large batch. In the status page for the batch import job, on completion, it will show links at the bottom of the page for newly created resources so you can check them without waiting for reindexing to complete. ( I’ve run into a few cases where import is successful, but it doesn’t display resources at the end. Not sure what the bug is there. )

Are you sure those missing resources aren’t findable now that reindexing is complete ?

If you still can’t find them, you should be able to see (and delete) all of the resources via the backend API.

— Steve Majewski

On Oct 21, 2016, at 11:35 AM, Romero, Michelle <M.Romero at northeastern.edu<mailto:M.Romero at northeastern.edu>> wrote:

Sorry if this question has been asked before, but I wasn’t able to find anything in the list archives.  We’re using version v1.5.0.  I imported a large batch of EAD finding aids at the same time. The import completed with no errors, but, when I tried to find the resources, they weren't visible in the backend or front end. I thought the import failed and tried to re-import them.  However, when I attempted to re-import them, I received an error message that the id numbers were already in use.  By searching the id number, I was able to find the top level containers.  Most of them had archival objects attached which then allowed me to access the resource and delete it.  I then re-imported the EAD with no issues. However, there are four that don't have archival objects associated with the top level containers. Is there another way to find and delete these four resources?

Thank you in advance for your assistance,

Michelle Romero
Assistant Archivist, Archives and Special Collections Department
92 Snell Library
Northeastern University
360 Huntington Avenue
Boston, MA 02115-5000
(v) 617-373-7656 (f) 617-373-5409

Archivesspace_Users_Group mailing list
Archivesspace_Users_Group at lyralists.lyrasis.org<mailto:Archivesspace_Users_Group at lyralists.lyrasis.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20161021/63eac6c7/attachment.html>

More information about the Archivesspace_Users_Group mailing list