[Archivesspace_Users_Group] EAD export issues

Chris Fitzpatrick Chris.Fitzpatrick at lyrasis.org
Wed Jun 25 06:10:35 EDT 2014

Hi Adrienne,

Heh, well I actually like to hear about some of the problems, since it's good to hear how people are using / modifying AS, including how they dealing with migrating from AT. I might not have the answers, but I'll do my best...

Ok, so..so, it sounds like for these linked subjects these are pointing to agents, correct? So, AS is trying to create a new agent, but the relator value hasn't been added. Can you try adding the "other_unmapped" value to the "linked_agent_archival_record_relators" value list in the System > Manage Controlled Value Lists menu, then try the import? You might have to add your custom values to this list in order for the @relator values to be accepted....

b, chris.

Chris Fitzpatrick | Developer, ArchivesSpace
Skype: chrisfitzpat  | Phone: 918.236.6048
From: Adrienne Pruitt <adrienne.pruitt at bc.edu>
Sent: Tuesday, June 24, 2014 3:10 PM
To: Chris Fitzpatrick
Cc: Archivesspace_Users_Group at lyralists.lyrasis.org
Subject: Re: [Archivesspace_Users_Group] EAD export issues

Hi, Chris,

The EAD export issues we're having that aren't listed in PT already are due to our own customization of AT (adding oclc_naf as a source type for names, for example, or adding record group as a source type for subject terms), so I figure they aren't really your problem. :) I've tried to only report issues that I think affect everyone.

We are seeing a weird bug that's causing imports to fail, though. If one linked subject in an accession record has a subject role, but the remainder of the linked subjects don't, the import fails and we get this error:

AT Identifier:Accession->MS.2001.009
Status code: 400
Status text: Bad Request
{"error":{"linked_agents/1/relator":["Invalid value 'other_unmapped'....

It affects a large percentage of our accessions, due to some legacy cataloging practices where a "publisher" was a identified for printed items. If you have multiple linked subjects with assigned roles, the error doesn't occur.


On Mon, Jun 23, 2014 at 5:42 PM, Chris Fitzpatrick <Chris.Fitzpatrick at lyrasis.org<mailto:Chris.Fitzpatrick at lyrasis.org>> wrote:

Hi Adienne,

We've been working quite a bit on EAD export, as you've probably seen in PT.

What are the issues you are having that are not in the issue tracker?

best, chris.

Chris Fitzpatrick | Developer, ArchivesSpace
Skype: chrisfitzpat  | Phone: 918.236.6048<tel:918.236.6048>
From: archivesspace_users_group-bounces at lyralists.lyrasis.org<mailto:archivesspace_users_group-bounces at lyralists.lyrasis.org> <archivesspace_users_group-bounces at lyralists.lyrasis.org<mailto:archivesspace_users_group-bounces at lyralists.lyrasis.org>> on behalf of Adrienne Pruitt <adrienne.pruitt at bc.edu<mailto:adrienne.pruitt at bc.edu>>
Sent: Monday, June 23, 2014 9:49 PM
To: Archivesspace_Users_Group at lyralists.lyrasis.org<mailto:Archivesspace_Users_Group at lyralists.lyrasis.org>
Subject: [Archivesspace_Users_Group] EAD export issues

Hello, all,

There are a number of issues with exporting valid EAD from ArchivesSpace, some of them listed on PivotalTracker, and I'm wondering if there's a timeline for addressing them. We'll be exporting EAD to create PDFs, and we also use exported EAD as part of our workflow for the batch generation of archival objects. While we could, theoretically, clean up the exports with a stylesheet or scripting, it would be preferable if this worked out of the box. Is there a schedule for this? We had been hoping to go live in the fall. . .

Thanks very much,

Adrienne Pruitt
Processing Archivist
John J. Burns Library, Boston College

Adrienne Pruitt
Processing Archivist
John J. Burns Library, Boston College
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20140625/64b3ab8c/attachment.html>

More information about the Archivesspace_Users_Group mailing list