[Archivesspace_Users_Group] Issue with gems extensions ( sassc, bindex, ... ) on Mac with 3.2.0

Brian Hoffman brian.hoffman at lyrasis.org
Thu May 26 07:20:16 EDT 2022

Hi Steve,

This is a known unresolved issue – ArchivesSpace is built on Jruby, the premise being that it can sit entirely on the JVM and thus be portable as any Java app. But over the years various gems with extensions have crept into the application and broken that model – in the case of the sassc gem, we have actually been copying over the gem that was built in the 2.8.1 release to all subsequent releases because for some reason that one seems to work on most systems. I think the proper solution would be to eliminate gems that depend on c extensions, and figuring out a way to do that is one of the objectives of our next Rails environment upgrade. Suggestions from those who are smarter than me on how to resolve this are most welcome.


From: archivesspace_users_group-bounces at lyralists.lyrasis.org <archivesspace_users_group-bounces at lyralists.lyrasis.org> on behalf of Majewski, Steven Dennis (sdm7g) <sdm7g at virginia.edu>
Date: Monday, May 23, 2022 at 2:37 PM
To: Archivesspace Users Group <archivesspace_users_group at lyralists.lyrasis.org>
Subject: [Archivesspace_Users_Group] Issue with gems extensions ( sassc, bindex, ... ) on Mac with 3.2.0

I usually test out migrations and local plugins on my Mac laptop first before installing on a test server.
I ran into a couple of issues with 3.2.0 release.

Using the release downloaded from

Backend and frontend appeared to work and communicate with the separately installed Solr instance however the PUI gave system errors from the bundler relating to sassc-2.4.0

Looking at the log file, there were a number of messages about that and other gems:

Ignoring bindex-0.8.1 because its extensions are not built. Try: gem pristine bindex --version 0.8.1
Ignoring llhttp-ffi-0.3.1 because its extensions are not built. Try: gem pristine llhttp-ffi --version 0.3.1
Ignoring sassc-2.4.0 because its extensions are not built. Try: gem pristine sassc --version 2.4.0
I attempted to run ‘gem pristine’ after setting GEM_HOME, which seemed to do something, but didn’t fix the  issue. ( Doing these sorts of fixes are a bit confusing due to the way that JRuby is packaged in ArchivesSpace, so I may not have been doing it correctly. )

I finally tried building my own distribution from GitHub tag v3.2.0, and unpacking that zip file and running it appears to work ( so far! Still indexing PUI )

So I’m guessing that there is something in these gem extensions that is architecture or java version specific and the distributions on GitHub are not universal.

We may require a fixup script that runs the bundler similar to the way it’s done in initialize-plugins script.

Has anyone else run into this issue ?

— Steve Majewski

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20220526/a4f58989/attachment.html>

More information about the Archivesspace_Users_Group mailing list