[Archivesspace_Users_Group] Issue with gems extensions ( sassc, bindex, ... ) on Mac with 3.2.0

Majewski, Steven Dennis (sdm7g) sdm7g at virginia.edu
Mon May 23 14:37:14 EDT 2022

I usually test out migrations and local plugins on my Mac laptop first before installing on a test server. 
I ran into a couple of issues with 3.2.0 release. 

Using the release downloaded from
https://github.com/archivesspace/archivesspace/releases/tag/v3.2.0 <https://github.com/archivesspace/archivesspace/releases/tag/v3.2.0>

Backend and frontend appeared to work and communicate with the separately installed Solr instance however the PUI gave system errors from the bundler relating to sassc-2.4.0 

Looking at the log file, there were a number of messages about that and other gems:

Ignoring bindex-0.8.1 because its extensions are not built. Try: gem pristine bindex --version 0.8.1
Ignoring llhttp-ffi-0.3.1 because its extensions are not built. Try: gem pristine llhttp-ffi --version 0.3.1
Ignoring sassc-2.4.0 because its extensions are not built. Try: gem pristine sassc --version 2.4.0

I attempted to run ‘gem pristine’ after setting GEM_HOME, which seemed to do something, but didn’t fix the  issue. ( Doing these sorts of fixes are a bit confusing due to the way that JRuby is packaged in ArchivesSpace, so I may not have been doing it correctly. ) 

I finally tried building my own distribution from GitHub tag v3.2.0, and unpacking that zip file and running it appears to work ( so far! Still indexing PUI ) 

So I’m guessing that there is something in these gem extensions that is architecture or java version specific and the distributions on GitHub are not universal. 

We may require a fixup script that runs the bundler similar to the way it’s done in initialize-plugins script. 

Has anyone else run into this issue ? 

— Steve Majewski

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20220523/a08df2bb/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 3342 bytes
Desc: not available
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20220523/a08df2bb/attachment.bin>

More information about the Archivesspace_Users_Group mailing list