[Archivesspace_Users_Group] Error when trying to add Event Type

Olivia S Solis livsolis at utexas.edu
Tue May 4 12:02:05 EDT 2021

Hi all,

I'm not sure if anyone else has experienced this in the past 3 years, but
wanted to follow up as our Systems Archivist and I have apparently had the
same problem. Background: since we don't use Digital Objects in ASpace, we
do not use a lot of the out-of-the-box Events, but we do track a lot of
processing steps using Events record. We do not want to delete any Events
that are native to ASpace so have suppressed many of them. Total, we have
44 events with 27 of the ASpace-native events suppressed. Though we plan to
upgrade soon, we're on ASpace version 2.4.1.

For the new Events that we've created for tracking processing steps, we
have generally posted them via the API and modified the yml file to add the
translations. We've always been able to create new events with no
problems... that is until yesterday when we tried to add two new ones and
failed trying two different ways:

   1. Posing via the API. The values appear to post. There are no error
   messages, but when we look in the staff interface GUI and check the
   database's enumeration_value table, the new events aren't there.
   2. Adding the new event via Manage Controlled Value Lists

This screenshot is the error we get when we try 2:
[image: Screen Shot 2021-05-04 at 8.26.28 AM.png]
I just tried going to the staff interface GUI and unsuppressing 7 events
that we normally suppress. I was still unable to add new events.

Has anyone else experienced this recently? Is there a documented solution
to the problem?


On Mon, Oct 29, 2018 at 1:46 PM Busch, Ed <buschedw at msu.edu> wrote:

> I haven't quite figured out the exact sequence of steps but I have figured
> out how to make it work. I had suppressed a number of the event types
> (most) and that seems to have been what caused creating to fail. I
> unsuppressed them and I could create again. I slowly suppressed them again
> in groups and around #26 was when I could no longer create or delete event
> types. I unsuppressed one and I could create again. SO, something seems to
> happen after the 25th is suppressed.
> Ed
> -----Original Message-----
> From: archivesspace_users_group-bounces at lyralists.lyrasis.org <
> archivesspace_users_group-bounces at lyralists.lyrasis.org> On Behalf Of
> Majewski, Steven Dennis (sdm7g)
> Sent: Monday, October 29, 2018 12:45 PM
> To: Archivesspace Users Group <
> archivesspace_users_group at lyralists.lyrasis.org>
> Subject: Re: [Archivesspace_Users_Group] Error when trying to add Event
> Type
> You could also try adding an enum value from the backend API and see if
> you get a more specific error message directly from the backend.
> — Steve Majewski
> > On Oct 29, 2018, at 12:20 PM, Majewski, Steven Dennis (sdm7g) <
> sdm7g at virginia.edu> wrote:
> >
> >
> >> On Oct 29, 2018, at 11:07 AM, Busch, Ed <buschedw at msu.edu> wrote:
> >>
> >> Hi-
> >>
> >> Nothing showing up in the log regarding the create event type error.
> System info report says the log level is set to debug. Any other ideas?
> >>
> >> Not sure if this is related, but I noticed that when I am logged as me
> (with admin priv), I can't access the system_info page: I get Unable to
> access Page. When I log in as the actual Admin user, I can access the page.
> >>
> >
> > Not related. System info controller is checking that user = “admin”
> instead of checking that user has admin privileges, which would probably be
> a better choice.
> >
> > Any clues at all in the log?  Can you post a snippet from around the
> time of the submit ?
> >
> >
> > — Steve Majewski
> >
> >
> >
> >
> > _______________________________________________
> > Archivesspace_Users_Group mailing list
> > Archivesspace_Users_Group at lyralists.lyrasis.org
> > http://lyralists.lyrasis.org/mailman/listinfo/archivesspace_users_grou
> > p
> _______________________________________________
> Archivesspace_Users_Group mailing list
> Archivesspace_Users_Group at lyralists.lyrasis.org
> http://lyralists.lyrasis.org/mailman/listinfo/archivesspace_users_group

Olivia Solis, MSIS
Metadata Coordinator
Dolph Briscoe Center for American History
The University of Texas at Austin
2300 Red River St. Stop D1100
Austin TX, 78712-1426
(512) 232-8013
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20210504/ee3d2e45/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Screen Shot 2021-05-04 at 8.26.28 AM.png
Type: image/png
Size: 40377 bytes
Desc: not available
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20210504/ee3d2e45/attachment.png>

More information about the Archivesspace_Users_Group mailing list