[Archivesspace_Users_Group] Line Breaks (Windows/UNIX)

Andrew Morrison andrew.morrison at bodleian.ox.ac.uk
Mon Mar 15 07:08:15 EDT 2021

How have you managed to get the UNIX LF-only line breaks to work in the 
staff interface view mode? Normally, web browsers don't render them. 
Have you used CSS? Or are you searching and replacing them with HTML br 


On 08/03/2021 15:39, RENTON Scott wrote:
> Hi folks,
> Sorry to have two tickets in at once. I tried this one out on the 
> Google Group- thought I'd hit paydirt, but then discovered the advice 
> was helpful but didn't solve the issue.
> We're just trying to get our heads round line breaks assignation. We 
> have an archivist who is cataloguing content, and we notice through 
> the API that they are being recorded with Windows (CR-LF) line endings.
>  "subnotes": [
>         {
> "jsonmodel_type": "note_text",
> "content": "Recorded by E. Sinclair on Vatersay in 1962, (eg. 
> SA1962.05)*\r\n\r\n*Recorded by James Ross on Vatersay in 1956, 
> (eg.SA1956.069.1, SA1956.087)*\r\n\r\n*This lady is great (SA1960.124 
> proverbs)! JB 9/6/09*\r\n\r\n*There is a duplicate 5810 - use this 
> one. EmM 9/6/09*\r\n\r\n*biog info on SA1958.157 track 3. \"Brief 
> history of contributor.*\r\n\r\n*Nan MacKinnon was born in Kentangaval 
> in 1903, and moved to Vatersay at age four. She spent several years 
> working on the mainland, then came home and worked at the herring. She 
> learned most of her songs when she came home, from her mother.\" more 
> detail on tape, mentions other place names.",
> "publish": false
>         }
> It appears that these line breaks do not appear in 'View' mode in the 
> frontend as being respected, but while we can see them in 'Edit' mode, 
> the cataloguers do need to see the line breaks in 'View' mode. If we 
> were seeing UNIX LF endings (\n), it does seem to work.
> We thought it was just that the users had been cutting and pasting 
> from a Word Doc, and if we changed manually in the interface they'd be 
> fixed, but apparently not. Even copying in the content in the attached 
> file- which I've converted to UNIX file endings results in Windows 
> ones. Is it possible there's a hidden character I'm not converting 
> that's governing all of this?
> Cheers
> Scott
> ==========
> Scott Renton
> Digital Library Development & Systems
> Floor F East
> Argyle House
> 515219
> The University of Edinburgh is a charitable body, registered in 
> Scotland, with registration number SC005336. Is e buidheann 
> carthannais a th’ ann an Oilthigh Dhùn Èideann, clàraichte an Alba, 
> àireamh clàraidh SC005336.
> _______________________________________________
> Archivesspace_Users_Group mailing list
> Archivesspace_Users_Group at lyralists.lyrasis.org
> http://lyralists.lyrasis.org/mailman/listinfo/archivesspace_users_group
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20210315/862c772c/attachment.html>

More information about the Archivesspace_Users_Group mailing list