[Archivesspace_Users_Group] Trouble with creating a Docker container

Peter Heiner ph448 at cam.ac.uk
Mon Jun 7 16:42:02 EDT 2021

I'm attempting to create a Docker container for ArchivesSpace and I cannot seem to get it to connect to my MySQL container. I'm still very new to Docker, so I'm sure there is a step in the process I am missing. My repo is here: https://github.com/pshowell23/aspace-docker<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fpshowell23%2Faspace-docker&data=04%7C01%7Cph448%40universityofcambridgecloud.onmicrosoft.com%7C9bd025e5be3d4e6f367508d929d5c638%7C49a50445bdfa4b79ade3547b4f3986e9%7C1%7C0%7C637586820394075495%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=Ixa6bNURZn6794Am2qravnqtPWAadbkNBMPbebisUJw%3D&reserved=0> and the error I keep getting is attached.

Sorry to be a bother, but I just don't understand where I've gone wrong. I tried adding environment variables in the docker-compose file and I've tried changing the config.rb file.
'localhost', the hostname for the IP address '', is meaningless in a container, you can't connect to it. What's more, MySQL's convention is that 'localhost' does not mean a TCP connection, but a UNIX socket connection, which will not work either. The solution is to use the hostname of the database container from the compose file in the connection string:

AppConfig[:db_url] = "jdbc:mysql://aspace_data:3306/archivesspace?user=as&password=as123&useUnicode=true&characterEncoding=UTF-8"

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20210607/bc0d5362/attachment.html>

More information about the Archivesspace_Users_Group mailing list