[Archivesspace_Users_Group] ArchivesSpace 2.8.1 Edit Default Values

Kim Pham Kim.Pham60 at du.edu
Wed Jan 6 14:53:46 EST 2021

Hi Andrew - Ahh, it looks like that's what I needed to do, it works now. Thanks a lot!

Kim Pham
Information Technologies Librarian, University of Denver
From: archivesspace_users_group-bounces at lyralists.lyrasis.org <archivesspace_users_group-bounces at lyralists.lyrasis.org> on behalf of Andrew Morrison <andrew.morrison at bodleian.ox.ac.uk>
Sent: Wednesday, December 30, 2020 03:49
To: archivesspace_users_group at lyralists.lyrasis.org <archivesspace_users_group at lyralists.lyrasis.org>
Subject: Re: [Archivesspace_Users_Group] ArchivesSpace 2.8.1 Edit Default Values

Is "Pre-populate Records?" checked in your own user preferences? User preferences take precedence over repository preferences, and both take precedence over global preferences. Initially your user preferences are unset, so a checkbox like "Pre-populate Records?" will appear unticked, but if it is enabled in repository or global preferences then it will work. However, if you edit your user preferences, for example to change the columns in a list view, when you click save that unticked checkbox means the feature will be disabled, for you, from that point on.

I do not think there is any way to return a user account to its initial state except by deleting a row in the MySQL database. It would be better if single checkboxes were replaced with three radio buttons labeled something like "Yes", "No", and "Use repository/global setting". Better yet, if admins could lock them into the last of those three, preventing users from changing them, then you could enforce policies like always user default values. But I suspect that would require a lot of work to implement and test.

Another thing to look out for is that default values are set up on a per-repository basis. So you can have "Pre-populate Records?" enabled in global preferences, but it will only actually work globally if all the repositories in your system have been set up with default values.


On 22/12/2020 16:23, Kim Pham wrote:

I'm having trouble with the edit default values feature in 2.8.1. I'm trying it with Resource records, and it works in our current 2.7.0 version, but it is not working in the 2.8.1 version that we want to launch. I enabled Pre-populate in the global and repository preferences but our values still don't show up. I also tried the online sandbox http://sandbox.archivesspace.org/<https://urldefense.com/v3/__http://sandbox.archivesspace.org/__;!!NCZxaNi9jForCP_SxBKJCA!FkSTtTlPSlTbuiJmhXvTgAUBmFNZIqSuACvwd8HBeiLk8Wn-0lxQSodKLGbJHt9uPg$>. Is anyone else experiencing issues with this feature? Thanks,

Kim Pham
Information Technologies Librarian, University of Denver

Archivesspace_Users_Group mailing list
Archivesspace_Users_Group at lyralists.lyrasis.org<mailto:Archivesspace_Users_Group at lyralists.lyrasis.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20210106/73bfd148/attachment.html>

More information about the Archivesspace_Users_Group mailing list