[Archivesspace_Users_Group] Can't login to backend after v3.0.2 upgrade

Blake Carver blake.carver at lyrasis.org
Tue Aug 24 18:54:33 EDT 2021

Can you also check your proxy for errors?
Was there any ERROR or FATAL lines in the ArchivesSpace logs?
From: archivesspace_users_group-bounces at lyralists.lyrasis.org <archivesspace_users_group-bounces at lyralists.lyrasis.org> on behalf of Schanz, Megan <schanzme at msu.edu>
Sent: Tuesday, August 24, 2021 1:04 PM
To: Archivesspace Users Group <archivesspace_users_group at lyralists.lyrasis.org>
Subject: [Archivesspace_Users_Group] Can't login to backend after v3.0.2 upgrade

Hi all,

I recently tried upgrading from v2.8.1 to v3.0.2. The upgrade itself went smoothly (database migrations run and full Solr reindex), but users are not able to login to the staff side.

After a successful login we see the green message: "Login Successful. Redirecting....", which then immediately shows this red message: "Your session expired due to inactivity"; never letting me get past the login page. I have tried with my user as well as the admin user with the same results. There are no errors in the log, but show these debug messages:

D, [2021-08-23T09:56:58.116731 #56] DEBUG -- : Thread-4056: POST /users/admin/login [session: nil]
D, [2021-08-23T09:56:58.122502 #56] DEBUG -- : Thread-4056: Post-processed params: {"password"=>"[FILTERED]", "username"=>"admin", "expiring"=>true}
D, [2021-08-23T09:56:58.260237 #56] DEBUG -- : Thread-4056: Responded with [200, {"Content-Type"=>"application/json", "Cache-Control"=>"private, must-revalidate, max-age=0", "Content-Length"=>"2981"}, ["{\"session\":\"70e1e356292a453b6e292a55e822287e41d53caedccf6bf7633735990cdec309\",\"user\":{\"lock_version\":53,\"username\":\"admin\",\"name\":\"Administrator\",\"is_system_user\":true,\"create_time\":\"2018-09-17T08:12:28Z\",\"system_mtime\":\"2021-08-23T13:56:58Z\",\"user_mtime\":\"2021-08-23T13:56:58Z\",\"jsonmodel_type\":\"user\",\"groups\":[],\"is_admin\":true,\"uri\":\"/users... in 143ms

I tried increasing the session_expire_after_seconds and session_nonexpirable_force_expire_after_seconds to see if that allowed me to login, but there was no change in the behavior.

Did anyone else experience this and find a resolution?



Megan Schanz
Application Developer & Systems Administrator
Michigan State University Libraries
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20210824/aeeb25be/attachment.html>

More information about the Archivesspace_Users_Group mailing list