[Archivesspace_Users_Group] PDF export issue

Custer, Mark mark.custer at yale.edu
Tue Sep 29 14:12:20 EDT 2020

Steve, all:

It looks like it does cause an issue for the PUI PDFs, as well, at least with an example that I just tested thanks to Maura Carbone, who provided a sample bit of text to try (hi, Maura!).  See:  http://test.archivesspace.org/repositories/2/archival_objects/3909.

When I tried the PUI PDF option in that case, the contents of the note were entirely missing (whereas on the staff side, the process replaces any glyphs that are not found in the current font with the "#" character).  The PUI PDF process is handled quite differently, though, since that process goes from HTML to PDF.

In both cases, it seems like there should be easier configuration options, since there's no font (or even font family) that's going to cover all character sets.

With Apache FOP, which is used on the staff side, you can configure FOP to auto-detect fonts but you'd still need to make sure to add the fonts where FOP can find them. That said, since the "stylesheets" directory in ASpace is not part of the WAR files, I'd think you could just update those files on the server without too much trouble.  Here's some info on that https://xmlgraphics.apache.org/fop/2.1/fonts.html#bulk.  Then you'd just need to update the transformation file, which is also in that "stylesheets" directory.

I just did that to test things out and that worked.  Example:

  *   Download new fonts, e.g. https://ctan.org/pkg/ipaex
  *   Add those to the fop-config.xml file
  *   Update the as-ead-pdf.xsl file to refer to the new fonts (and this last bit could be handled with a parameter or other means).  That said, it would be ideal in ASpace to be able to specify the language contents of the description to clearly indicate the language and scripts that are in use, especially if you want to switch between fonts for different scripts, etc.

Example screenshot attached.


From: archivesspace_users_group-bounces at lyralists.lyrasis.org <archivesspace_users_group-bounces at lyralists.lyrasis.org> on behalf of Majewski, Steven Dennis (sdm7g) <sdm7g at virginia.edu>
Sent: Tuesday, September 29, 2020 12:41 PM
To: Archivesspace Users Group <archivesspace_users_group at lyralists.lyrasis.org>
Subject: Re: [Archivesspace_Users_Group] PDF export issue

Yes, a sample would be useful to try to reproduce the issue.  It would also be interesting to know if both the staff PDF export and the PUI PDF show the same problems.  ― Steve M.

On Sep 29, 2020, at 11:42 AM, Custer, Mark <mark.custer at yale.edu<mailto:mark.custer at yale.edu>> wrote:

Dear Hitomi Matsuyama,

Which version of ArchivesSpace are you using?

I'm not familiar with those configuratio settings, but I suspect that they might just be for the PDF formats of the Reports, not for the PDF format of the EAD conversion process.

On newer releases of ArchivesSpace, the default font for the EAD to PDF conversion has been updated to use the NotoSerif font family.  See:  https://github.com/archivesspace/archivesspace/blob/master/stylesheets/fop-config.xml<https://nam05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Farchivesspace%2Farchivesspace%2Fblob%2Fmaster%2Fstylesheets%2Ffop-config.xml&data=02%7C01%7Cmark.custer%40yale.edu%7Cd4c75b35b1714671fcbe08d864967821%7Cdd8cbebb21394df8b4114e3e87abeb5c%7C0%7C0%7C637369944713065294&sdata=%2F9jPeYIWU7HinnFKnvfIBHnQ1kBeqisWBO%2FoSQDgDQc%3D&reserved=0>, https://github.com/archivesspace/archivesspace/tree/master/stylesheets/fonts<https://nam05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Farchivesspace%2Farchivesspace%2Ftree%2Fmaster%2Fstylesheets%2Ffonts&data=02%7C01%7Cmark.custer%40yale.edu%7Cd4c75b35b1714671fcbe08d864967821%7Cdd8cbebb21394df8b4114e3e87abeb5c%7C0%7C0%7C637369944713065294&sdata=u3R%2BFWV%2Bv41D4mTA1hRZWLiGC%2BYmg%2BPcLexDaOaLSic%3D&reserved=0>, and https://github.com/archivesspace/archivesspace/blob/5da6428562b65493fc087fe3543c4d292f10ff0e/stylesheets/as-ead-pdf.xsl#L124<https://nam05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Farchivesspace%2Farchivesspace%2Fblob%2F5da6428562b65493fc087fe3543c4d292f10ff0e%2Fstylesheets%2Fas-ead-pdf.xsl%23L124&data=02%7C01%7Cmark.custer%40yale.edu%7Cd4c75b35b1714671fcbe08d864967821%7Cdd8cbebb21394df8b4114e3e87abeb5c%7C0%7C0%7C637369944713075246&sdata=amw20LBQSraASfYeoVW3TiThXqi2D%2BxtLkTan3N10fU%3D&reserved=0>

Also, I am assuming that you are referring to the EAD to PDF process in the ArchivesSpace staff interface, i.e. Export --> Generate PDF.  If that's not right, just let me know. If that is right, could you share a sample EAD file that could be used for testing with a different font?

All my best,


From: archivesspace_users_group-bounces at lyralists.lyrasis.org<mailto:archivesspace_users_group-bounces at lyralists.lyrasis.org> <archivesspace_users_group-bounces at lyralists.lyrasis.org<mailto:archivesspace_users_group-bounces at lyralists.lyrasis.org>> on behalf of Hitomi Matsuyama <matsuyama at nak-osaka.jp<mailto:matsuyama at nak-osaka.jp>>
Sent: Tuesday, September 29, 2020 4:26 AM
To: archivesspace_users_group at lyralists.lyrasis.org<mailto:archivesspace_users_group at lyralists.lyrasis.org> <archivesspace_users_group at lyralists.lyrasis.org<mailto:archivesspace_users_group at lyralists.lyrasis.org>>
Subject: [Archivesspace_Users_Group] PDF export issue

Hello all,

We've had some trouble with PDF export in Japanese.
Descriptive information written with Japanese characters, hiragana, katakana, and kanji, are not exported to ArchivesSpace formatted finding-aids at all.

Our IT staff has tried to modify config.rb as follows in order to add some Japanese specific font types;

AppConfig[:report_pdf_font_paths] = proc { ["#{AppConfig[:backend_url]}/reports/static/fonts/ipa/ipag.ttf"] } AppConfig[:report_pdf_font_family] = "IPAexゴシック, \"IPA Pゴシック\",
\"ヒラギノ角ゴ ProN W3\", \"Hiragino Kaku Gothic ProN\", メイリオ, Meiryo, \"MS Pゴシック\", sans-serif"

However, this doesn’t work out and the description in Japanese is still missing in a PDF.
Have any non-alphabet language users ever faced the same problem?
If it’s been already solved, let us know how to get through.

Thank you!

Hitomi Matsuyama, Audiovisual Archivist

Nakanoshima Museum of Art, Osaka
1-1-86-8F Noda, Fukushima-ku
Osaka 553-0005 JAPAN
tel. +81 (0)6 64 69 51 93
email. matsuyama at nak-osaka.jp<mailto:matsuyama at nak-osaka.jp>

Archivesspace_Users_Group mailing list
Archivesspace_Users_Group at lyralists.lyrasis.org<mailto:Archivesspace_Users_Group at lyralists.lyrasis.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20200929/905ab277/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Screen Shot 2020-09-29 at 1.56.55 PM.png
Type: image/png
Size: 35349 bytes
Desc: Screen Shot 2020-09-29 at 1.56.55 PM.png
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20200929/905ab277/attachment.png>

More information about the Archivesspace_Users_Group mailing list