[Archivesspace_Users_Group] PDF export issue

Custer, Mark mark.custer at yale.edu
Tue Sep 29 11:42:54 EDT 2020

Dear Hitomi Matsuyama,

Which version of ArchivesSpace are you using?

I'm not familiar with those configuratio settings, but I suspect that they might just be for the PDF formats of the Reports, not for the PDF format of the EAD conversion process.

On newer releases of ArchivesSpace, the default font for the EAD to PDF conversion has been updated to use the NotoSerif font family.  See:  https://github.com/archivesspace/archivesspace/blob/master/stylesheets/fop-config.xml, https://github.com/archivesspace/archivesspace/tree/master/stylesheets/fonts, and https://github.com/archivesspace/archivesspace/blob/5da6428562b65493fc087fe3543c4d292f10ff0e/stylesheets/as-ead-pdf.xsl#L124

Also, I am assuming that you are referring to the EAD to PDF process in the ArchivesSpace staff interface, i.e. Export --> Generate PDF.  If that's not right, just let me know. If that is right, could you share a sample EAD file that could be used for testing with a different font?

All my best,


From: archivesspace_users_group-bounces at lyralists.lyrasis.org <archivesspace_users_group-bounces at lyralists.lyrasis.org> on behalf of Hitomi Matsuyama <matsuyama at nak-osaka.jp>
Sent: Tuesday, September 29, 2020 4:26 AM
To: archivesspace_users_group at lyralists.lyrasis.org <archivesspace_users_group at lyralists.lyrasis.org>
Subject: [Archivesspace_Users_Group] PDF export issue

Hello all,

We've had some trouble with PDF export in Japanese.

Descriptive information written with Japanese characters, hiragana, katakana, and kanji, are not exported to ArchivesSpace formatted finding-aids at all.

Our IT staff has tried to modify config.rb as follows in order to add some Japanese specific font types;

AppConfig[:report_pdf_font_paths] = proc { ["#{AppConfig[:backend_url]}/reports/static/fonts/ipa/ipag.ttf"] } AppConfig[:report_pdf_font_family] = "IPAexゴシック, \"IPA Pゴシック\",

\"ヒラギノ角ゴ ProN W3\", \"Hiragino Kaku Gothic ProN\", メイリオ, Meiryo, \"MS Pゴシック\", sans-serif"

However, this doesn’t work out and the description in Japanese is still missing in a PDF.

Have any non-alphabet language users ever faced the same problem?

If it’s been already solved, let us know how to get through.

Thank you!

Hitomi Matsuyama, Audiovisual Archivist

Nakanoshima Museum of Art, Osaka

1-1-86-8F Noda, Fukushima-ku

Osaka 553-0005 JAPAN

tel. +81 (0)6 64 69 51 93

email. matsuyama at nak-osaka.jp

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20200929/e2058257/attachment.html>

More information about the Archivesspace_Users_Group mailing list