[Archivesspace_Users_Group] ArchivesSpace color scheme customization

Huebschen, Alan M ahueb2 at uis.edu
Tue Sep 11 14:07:04 EDT 2018

Excluding test development doc fixed the issue, thanks for the help Steve!

-Alan Huebschen
Brookens Library
Information Systems
(217) 206-7115

From: Majewski, Steven Dennis (sdm7g) <sdm7g at virginia.edu>
Sent: Tuesday, September 11, 2018 12:47 PM
To: Huebschen, Alan M <ahueb2 at uis.edu>
Cc: Archivesspace Users Group <archivesspace_users_group at lyralists.lyrasis.org>
Subject: Re: [Archivesspace_Users_Group] ArchivesSpace color scheme customization

public_suffix-3.0.2 is in the build/gems/gems/ directory in my source/development repo, however I don’t see it in an unpacked production server distribution gems directory.

I find it in public/Gemfile.lock:


Nothing about those specs has changed immediately before or after v2.5.0 release, but the commit for that addition
4 months ago says it was to “Add Capybara + Selenium test to PUI” and public_suffix appears to be pulled in as part
of those gems.

Looking in public/Gemfile, capybara gem is inside a 'group :test do’ block:


So it would appear that those gems are only included for test in the development server and aren’t packaged for production server.

Are you building public.war as a build.xml target ? : ‘./build/run public:war’

Looking at the dist build target in build/build.xml, I see that when it calls the war file build targets,
it sets an excluded-gem-groups parameter to “test development doc” .

This is probably the source of you problem.

  <target name="dist"
          description="Build a standalone distribution zip of all components">

    <antcall target="set-classpath" />
    <antcall target="bootstrap"><param name="excluded-gem-groups" value="test development doc" /></antcall>
    <antcall target="oai:war"><param name="excluded-gem-groups" value="test development doc" /></antcall>
    <antcall target="backend:war"><param name="excluded-gem-groups" value="test development doc" /></antcall>
    <antcall target="frontend:war"><param name="excluded-gem-groups" value="test development doc" /></antcall>
    <antcall target="public:war"><param name="excluded-gem-groups" value="test development doc" /></antcall>
    <antcall target="solr:war"><param name="excluded-gem-groups" value="test development doc" /></antcall>
    <antcall target="indexer:war"><param name="excluded-gem-groups" value="test development doc" /></antcall>
    <antcall target="build-zip"><param name="excluded-gem-groups" value="test development doc" /></antcall>

— Steve M.

On Sep 11, 2018, at 1:06 PM, Huebschen, Alan M <ahueb2 at uis.edu<mailto:ahueb2 at uis.edu>> wrote:

I’ve attached a screenshot of the full error.
I’ve tried using the source code using git checkout 2.5.0 and downloading the source code directly from the v2.5.0 release, both list “v2.5.0.a” at the bottom of the rendered pages for the frontend and public interface, the same error occurs when building the public.war file from both sources. I have also tried taking the public.war file directly out of the official v2.5.0 release, opening it with winrar and replacing the colors.scss file which had absolutely no effect (no changes and no errors).
I decided to build just the war file because I figured it might make upgrades go a little smoother in the future.

-Alan Huebschen
Brookens Library
Information Systems
(217) 206-7115

From: Majewski, Steven Dennis (sdm7g) <sdm7g at virginia.edu<mailto:sdm7g at virginia.edu>>
Sent: Tuesday, September 11, 2018 10:49 AM
To: Huebschen, Alan M <ahueb2 at uis.edu<mailto:ahueb2 at uis.edu>>
Subject: Re: [Archivesspace_Users_Group] ArchivesSpace color scheme customization

What sort of errors are you getting in the log file ?

I don’t know what you mean by “2.5.0.a” source code:
Are you working with git tag v2.5.0 or source code release from https://github.com/archivesspace/archivesspace/releases/tag/v2.5.0  ?

Why not build a complete distribution instead of just replacing public war file ?
( I can imagine ways that source code and distribution could get out of sync… )

— Steve Majewski

On Sep 11, 2018, at 9:53 AM, Huebschen, Alan M <ahueb2 at uis.edu<mailto:ahueb2 at uis.edu>> wrote:

Hi all,

I’ve been working on customizing the ArchivesSpace public interface for our institution, but I keep running into issues when trying to change the colors used under ./public/app/assets/stylesheets/archivesspace/colors.scss. I’m running version 2.5.0 on our test instance and working with the 2.5.0.a source code. Every time I compile the public.war file and replace it in the wars folder in my test distribution, I get an internal server error 500. The only thing I’ve been changing are the hex values for the colors, so I would think these files should be easily interchangeable. Does anyone have some insight? Any help would be appreciated.

-Alan Huebschen
Brookens Library
Information Systems
(217) 206-7115

Archivesspace_Users_Group mailing list
Archivesspace_Users_Group at lyralists.lyrasis.org<mailto:Archivesspace_Users_Group at lyralists.lyrasis.org>

<2018-09-11 12_01_54-Internal Server Error at _ - Firefox Developer Editi....png>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20180911/75c526ac/attachment.html>

More information about the Archivesspace_Users_Group mailing list