[Archivesspace_Users_Group] Subject Heading Plugin not working properly 1.4.2

Majewski, Steven Dennis (sdm7g) sdm7g at eservices.virginia.edu
Thu Jun 15 13:26:53 EDT 2017

It appears to be no longer working in any version.
I believe loc has changed the API for the service slightly. Need to investigate further.
But trying to reverse engineer the parameters from inspecting the difference in the params used in the web page search vs. what’s embedded in LCNAF plugin, I tried this change, which appears to work for me:

diff --git a/plugins/lcnaf/frontend/models/opensearcher.rb b/plugins/lcnaf/frontend/models/opensearcher.rb
index 9391ab5..37e2813 100644
--- a/plugins/lcnaf/frontend/models/opensearcher.rb
+++ b/plugins/lcnaf/frontend/models/opensearcher.rb
@@ -14,7 +14,7 @@ class OpenSearcher

   def initialize(base_url, scheme )
     @base_url = base_url
-    @scheme = scheme
+    @scheme = "cs:" + scheme

@@ -71,7 +71,7 @@ class OpenSearcher
                                   'start' => start_record)

     uri.query = URI.encode_www_form(params)
+    p uri
     results = HTTPRequest.new.get(uri) do |response|
       if response.code != '200'
         raise OpenSearchException.new("Error during OpenSearch search: #{response.body}")

( The other OCLC search has always been unreliable — it’s a test site and not a supported service. )

— Steve Majewski

On Jun 15, 2017, at 12:07 PM, Maurice, Candace A <cmaurice at tulane.edu<mailto:cmaurice at tulane.edu>> wrote:

Hello All,

We are on version 1.4.2 and we have had a user report that the subject heading plugin is not returning results for either LCNAF or LCSH (OCLC works, however). The user doesn’t receive any error messages when using the plugin,  but tried typing in known subject headings for the Library Of Congress and it’s still not returning results. I checked the  Background jobs and logs and there are not error messages. I also went to the LOC website and all appears to be fine when searching subject headings on their site.

Has anyone else experienced a similar issue? Can you point me in the right direction for resolving this issue?



Candace Maurice
Web Developer
Howard-Tiltion Memorial Library
Tulane University
cmaurice at tulane.edu<mailto:cmaurice at tulane.edu>
Archivesspace_Users_Group mailing list
Archivesspace_Users_Group at lyralists.lyrasis.org<mailto:Archivesspace_Users_Group at lyralists.lyrasis.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20170615/ebc6ec4d/attachment.html>

More information about the Archivesspace_Users_Group mailing list