[Archivesspace_Users_Group] archivesspace newbie questions

Majewski, Steven Dennis (sdm7g) sdm7g at eservices.virginia.edu
Wed Feb 10 12:01:47 EST 2016

The gem and binaries should be installed in the archivesspace build/gems directory, but ./build/gems/bin isn’t
on your path, and just running ./build/gems/bin/pry-remote will get an error unless you run it thru the bundler,
as it won’t find the pry-remote gems.

My hacked version of jirb script has a fallthru “$*” at the end.
I keep it in the parent directory of my archivesspace directory, so for me running:

../jirb.sh bundle exec pry-remote


But my procedures for AS development environment are constantly being tweaked as I run into new issues.
Lately, I’ve been trying to work RubyMine into the environment, but I can’t seem to be able to get it
to find my Gems in the correct place. Before finding method of ‘bundle exec’ with those environment settings,
I was keeping a duplicate set of Gems installed in the rbenv environment. I may have to go back to doing
that to get RubyMine to find them.

— Steve.

On Feb 10, 2016, at 9:34 AM, Esha Datta <esha at nyu.edu<mailto:esha at nyu.edu>> wrote:

Thanks for your email. I got the gem to install as you had mentioned; however, I'm not sure how to get pry-remote to work. I see the message:

[java] [pry-remote] Waiting for client on druby://<>

But, when I try to do pry-remote in the terminal, I get a bash error: command not found. I googled around trying to see how to run pry-remote within jruby and didn't find anything of value. These are the commands I tried:

1. pry-remote: Got an error: -bash: pry-remote: command not found

2. ./scripts/jruby -S pry-remote. Error: jruby: No such file or directory -- pry (LoadError)

Thanks for your help!


On Feb 9, 2016 11:28 PM, "Mayo, Dave" <dave_mayo at harvard.edu<mailto:dave_mayo at harvard.edu>> wrote:

Hi Esha,

As far as running bundler, I've found that running:

./build/run bundler -Dgemfile=../backend/Gemfile

from the archivesspace root directory gets the contents of that Gemfile installed properly.

I'm running my devserver via `.build/run backend:devserver`.  If you're doing the same, `binding.pry` STILL won't work, because the backend doesn't log directly to console, and whatever intermediate it's using (Ant? I think Ant) only does output.  What I DID get working was installing the pry-remote Gem, and then doing `binding.remote_pry` and connecting from another terminal.

Let me know if this works out for you, or if there's anything else I can possibly do to help.

- Dave Mayo
  Library Software Engineer
  Harvard University -> HUIT -> LTS

From:  Esha Datta <esha at nyu.edu<mailto:esha at nyu.edu>>
Reply-To:  "esha at nyu.edu<mailto:esha at nyu.edu>" <esha at nyu.edu<mailto:esha at nyu.edu>>, Archivesspace Users Group <archivesspace_users_group at lyralists.lyrasis.org<mailto:archivesspace_users_group at lyralists.lyrasis.org>>
Date:  Tuesday, February 9, 2016 at 8:04 PM
To:  "archivesspace_users_group at lyralists.lyrasis.org<mailto:archivesspace_users_group at lyralists.lyrasis.org>" <archivesspace_users_group at lyralists.lyrasis.org<mailto:archivesspace_users_group at lyralists.lyrasis.org>>
Subject:  [Archivesspace_Users_Group] archivesspace newbie questions


I'm a developer with NYU's Bobst Library and am new to JRuby and ArchivesSpace. I have to write a plugin and am trying to use pry for stepping through some code. I have done some rails work before and tried to install pry by adding it to the backend/ Gemfile
and then running ./scripts/jruby -S bundle install. The command ran but didn't install pry. I then tried to install it by doing the following:
./scripts/jruby -S gem install pry
That installed pry but when I tried to use it in the backend by doing "binding.pry", I got an error saying it's an undefined method. If anyone has pointers as to how to use pry in this environment, I'd really appreciate it. Basically, I'm trying to figure
out what certain objects have and return in order to write the plugin.

Also, I will need to write tests for the plugin. Sorry, if I've missed documentation in how to write tests for the plugin and how to run them. If someone could point me to that, I'd really appreciate it.

Thanks for your time.


Archivesspace_Users_Group mailing list
Archivesspace_Users_Group at lyralists.lyrasis.org<mailto:Archivesspace_Users_Group at lyralists.lyrasis.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20160210/f6238f67/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: jirb.sh
Type: application/octet-stream
Size: 1286 bytes
Desc: jirb.sh
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20160210/f6238f67/attachment.obj>

More information about the Archivesspace_Users_Group mailing list