[Archivesspace_Users_Group] archivesspace newbie questions

Mayo, Dave dave_mayo at harvard.edu
Tue Feb 9 23:28:34 EST 2016

Hi Esha,

As far as running bundler, I've found that running:

./build/run bundler -Dgemfile=../backend/Gemfile

from the archivesspace root directory gets the contents of that Gemfile installed properly.

I'm running my devserver via `.build/run backend:devserver`.  If you're doing the same, `binding.pry` STILL won't work, because the backend doesn't log directly to console, and whatever intermediate it's using (Ant? I think Ant) only does output.  What I DID get working was installing the pry-remote Gem, and then doing `binding.remote_pry` and connecting from another terminal.

Let me know if this works out for you, or if there's anything else I can possibly do to help.

- Dave Mayo
  Library Software Engineer
  Harvard University -> HUIT -> LTS

From:  Esha Datta <esha at nyu.edu<mailto:esha at nyu.edu>>
Reply-To:  "esha at nyu.edu<mailto:esha at nyu.edu>" <esha at nyu.edu<mailto:esha at nyu.edu>>, Archivesspace Users Group <archivesspace_users_group at lyralists.lyrasis.org<mailto:archivesspace_users_group at lyralists.lyrasis.org>>
Date:  Tuesday, February 9, 2016 at 8:04 PM
To:  "archivesspace_users_group at lyralists.lyrasis.org<mailto:archivesspace_users_group at lyralists.lyrasis.org>" <archivesspace_users_group at lyralists.lyrasis.org<mailto:archivesspace_users_group at lyralists.lyrasis.org>>
Subject:  [Archivesspace_Users_Group] archivesspace newbie questions


I'm a developer with NYU's Bobst Library and am new to JRuby and ArchivesSpace. I have to write a plugin and am trying to use pry for stepping through some code. I have done some rails work before and tried to install pry by adding it to the backend/ Gemfile
and then running ./scripts/jruby -S bundle install. The command ran but didn't install pry. I then tried to install it by doing the following:
./scripts/jruby -S gem install pry
That installed pry but when I tried to use it in the backend by doing "binding.pry", I got an error saying it's an undefined method. If anyone has pointers as to how to use pry in this environment, I'd really appreciate it. Basically, I'm trying to figure
out what certain objects have and return in order to write the plugin.

Also, I will need to write tests for the plugin. Sorry, if I've missed documentation in how to write tests for the plugin and how to run them. If someone could point me to that, I'd really appreciate it.

Thanks for your time.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20160210/c87ce2a4/attachment.html>

More information about the Archivesspace_Users_Group mailing list