[Archivesspace_Users_Group] ArchivesSpace 1.4.2 Jasper Reports not working

Fleming, Jason flemingj at uncw.edu
Thu Apr 28 14:24:41 EDT 2016

We were getting a similar error. We have a linux server so the Arial font is not available to jasperreports. After I installed mscorefonts it started working fine for the most part. The bottom three reports as noted by Patrick Galligan and Ben Goldman in November of 2015 are still not working. We are on 1.4.2

This might help (I am on RedHat 6)
Here are the instructions that mostly worked (make sure to change the mscorefont version to 2.5.1 as identified by comments section)


Jason Fleming
Information Technology Librarian
601 South College Road | Wilmington, NC  28403-5990
T: 910-962-2675 | flemingj at uncw.edu

-----Original Message-----
From: archivesspace_users_group-bounces at lyralists.lyrasis.org [mailto:archivesspace_users_group-bounces at lyralists.lyrasis.org] On Behalf Of Hambleton, John S
Sent: Thursday, April 28, 2016 9:31 AM
To: Archivesspace Users Group <archivesspace_users_group at lyralists.lyrasis.org>
Cc: No-aH <skiszka at nmu.edu>; Oliver, Catherine E <coliver at nmu.edu>
Subject: [Archivesspace_Users_Group] ArchivesSpace 1.4.2 Jasper Reports not working
Importance: High

Folks, when we upgraded to ArchivesSpace 1.4.2, the Jasper Reports (RepositoryProfile Report - through UnprocessedAccessions), were all working fine. Today, we needed to run some reports, and they either:
-Just run for a long time and produce no results, or -Produce an error that begins like this:
" DigitalObjectFileVersionsReport - net.sf.jasperreports.engine.util.JRFontNotFoundException: Font 'Arial' is not available to the JVM. See the Javadoc for more details.
message - Font 'Arial' is not available to the JVM. See the Javadoc for more details.
backtrace - net.sf.jasperreports.engine.fonts.FontUtil.checkAwtFont(net/sf/jasperreports/engine/fonts/FontUtil.java:357)"

It is kind of looking to me like the reason might be the name space for the reports has moved, that is, <jasperReport xmlns="http://jasperreports.sourceforge.net/jasperreports"...
the  http://jasperreports.sourceforge.net/jasperreports
is no longer available. 

Can anybody tell me what to do about this?

With thanks,

+ John S. Hambleton
+ Olson Library
+ Northern Michigan University
+ Marquette Michigan 49855
+ Phone: 906-227-2741
+ Ab alio expectes, alteri quod feceris

Archivesspace_Users_Group mailing list
Archivesspace_Users_Group at lyralists.lyrasis.org

More information about the Archivesspace_Users_Group mailing list