[Archivesspace_Users_Group] How to delete a populated repository?

Mark Cyzyk mcyzyk at jhu.edu
Wed Mar 25 16:52:02 EDT 2015


Does anyone know how to delete a populated repository?  (We 
inadvertently clicked the wrong thing while performing a migration which 
set in stone our previously-pushed-through erroneous recordset.)

I tried to Delete, but it won't delete a repository if it is populated.
I tried to simply move that repository, transferring its content into a 
dummy repository for the time being.  No joy.  ("There was an error")
I reran the ./scripts/setup-database.sh script hoping it might drop each 
table before recreating/reinitializing.  No joy.
I attempted to Drop tables individually but can't because of foreign key 

The only other thing I can think to do is to drop, then recreate, the 
whole DB schema in MySQL (which, insofar as I don't have root access 
there, I can't do).

I kind of expected the Delete button would delete the repository -- 
including all its content -- and not leave behind any orphans in the 
backend database?

How can I delete this pesky repository?!

Advice much appreciated,



Mark Cyzyk, M.A., M.L.S.
Scholarly Communication Architect
User Interface Applications Group
The Sheridan Libraries
The Johns Hopkins University
mcyzyk at jhu.edu

Verba volant, scripta manent.

More information about the Archivesspace_Users_Group mailing list