[Archivesspace_Users_Group] Can't connect to frontend server: how to reset flash errors ?

brian brianjhoffman at gmail.com
Fri Mar 6 17:48:52 EST 2015

Thanks Steve. Should be an easy fix and i can send you a temporary plugin over the weekend.


Sent from my T-Mobile 4G LTE Device

<div>-------- Original message --------</div><div>From: Steven Majewski <sdm7g at virginia.edu> </div><div>Date:03/06/2015  5:38 PM  (GMT-05:00) </div><div>To: Archivesspace Users Group <archivesspace_users_group at lyralists.lyrasis.org> </div><div>Cc:  </div><div>Subject: [Archivesspace_Users_Group] Can't connect to frontend server: how	to reset flash errors ? </div><div>
Tried to merge two resources. It failed. Tried to go back to resource browse page.
Got “We’re sorry, but something went wrong.” message. 
Tried to load home page and got same message. 
Tried to shutdown and restart server. 
Get the same “We’re sorry, but something went wrong.” message. 
Repeat with same results.  

I can connect to the backend server and the public server, but not to the frontend server at any URL I’ve tried. 

Any idea what I need to reset ? 

It looks like it’s trying to flash an error message about the failed merge, but getting an error on that attempt. 

Logfile says: 

Started GET "/" for at 2015-03-06 17:26:24 -0500
Processing by WelcomeController#index as HTML
D, [2015-03-06T17:26:24.246000 #39193] DEBUG -- : Thread-3474: GET /users/current-user?repo_id=3 [session: #<Session:0xb1bce0e @store={:user=>"admin", :login_time=>2015-03-06 16:05:05 -0500, :expirable=>true}, @id="4fe87773e70a5bce3390dcd38537997f71ef7cbcdab78c92267347739c0a8af7">]
D, [2015-03-06T17:26:24.249000 #39193] DEBUG -- : Thread-3474: Post-processed params: {}
D, [2015-03-06T17:26:24.266000 #39193] DEBUG -- : Thread-3474: Responded with [200, {"Content-Type"=>"application/json", "Cache-Control"=>"private, must-revalidate, max-age=0", "Content-Length"=>"2120"}, ["{\"lock_version\":109,\"username\":\"admin\",\"name\":\"Administrator\",\"is_system_user\":true,\"create_time\":\"2015-02-18T17:00:05Z\",\"system_mtime\":\"2015-03-06T21:05:05Z\",\"user_mtime\":\"2015-03-06T21:05:05Z\",\"jsonmodel_type\":\"user\",\"groups\":[],\"is_admin\":true,\"uri\":\"/users/1\",\"agent_record\":{\"ref\":\"/agents/people/1\"},\"permissions\":{\"/repositories/1\":... in 29.0ms
  Rendered shared/_flash_messages.html.erb (5.0ms)
  Rendered welcome/index.html.erb within layouts/application (7.0ms)
Completed 500 Internal Server Error in 54.0ms

ActionView::Template::Error (undefined method `force_encoding' for #<Hash:0x2905ee47>):
    10: <% end %>
    11: <% if flash[:error] %>
    12:   <div class="alert alert-error">
    13:     <%= flash[:error].force_encoding("UTF-8") %>
    14:   </div>
    15: <% end %>
    16: <% if flash[:info] %>
  app/views/shared/_flash_messages.html.erb:13:in `_app_views_shared__flash_messages_html_erb___762147210_8170'
  app/helpers/application_helper.rb:228:in `render_aspace_partial'
  app/views/welcome/index.html.erb:4:in `_app_views_welcome_index_html_erb___489188543_8154'

Archivesspace_Users_Group mailing list
Archivesspace_Users_Group at lyralists.lyrasis.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20150306/88cb70fa/attachment.html>

More information about the Archivesspace_Users_Group mailing list