[Archivesspace_Users_Group] Archon to ArchivesSpace Migration Problems & Questions

Matthew J Gorzalski mGorzalski at lib.siu.edu
Thu Jul 2 14:03:46 EDT 2015

We just tried the batch replace and a remigration to see if it worked, but ran into an error that crashed the migration and are waiting for a response to Doug Simmons’ email yesterday afternoon.

But Phil, a lot of you’re issues are problems we’re experiencing too (we’re Archon users).  I will be talking about our migration adventure at SAA next month and highlight some of these same issues.  The reason classifications are duplicated is because Archon’s classification structure is shared globally throughout Archon, but in ASpace the classifications are replicated per repository.  I deleted our “bad” classifications post migration to knock it back down to 5 from the 30 ArchivesSpace spit out.

Matt Gorzalski
SIU Carbondale

From: archivesspace_users_group-bounces at lyralists.lyrasis.org [mailto:archivesspace_users_group-bounces at lyralists.lyrasis.org] On Behalf Of Maura Carbone
Sent: Thursday, July 02, 2015 11:54 AM
To: Archivesspace Users Group
Subject: Re: [Archivesspace_Users_Group] Archon to ArchivesSpace Migration Problems & Questions

Hi Phillip,
With regards to number 5, it is a known issue. I have one of the earlier emails about this saved: "This is not a bug, but rather has to do with how the information was entered into archon in the first place. To fix, a find-replace on all records with will need to done changing [i] into <i> and [/i] into </i>, directly on the backend data."

Brian detailed a bit more: "You can do this with the Batch Find and Replace feature (found in the “Background Jobs” section). But you need to test this first in a test environment using a copy of your database. When you are ready to proceed and use your production database, make sure to back it up first."

I'm not sure if something like that would need to be done for your other special characters as well.

On Thu, Jul 2, 2015 at 12:44 PM, Suda, Phillip J <psuda1 at tulane.edu<mailto:psuda1 at tulane.edu>> wrote:
Good morning all,

                 I have performed migrations from Archon to ArchivesSpace successfully. I have then upgraded to the most recent version of ArchivesSpace (v.1.3.0) for each of my instances. This all works better locally (MacBook for me). I have a few questions regarding problems we are noticing with the migrations. I do not know who to ask specifically, but here it goes:

1.       Public Interface Special Characters & Diacritics:

a.       Example: Alcée Fortier papers, 1894-1911 in Archon changes to Alc√©e Fortier papers in ArchivesSpace (v.1.04-v.1.3.0).

2.       Public Interface Scope & Content Notes: these are migrated to ArchivesSpace as large text blobs; they were formatted in Archon (indentation, paragraphs, etc.)

3.       Public Interface Repositories Odd Behavior:

a.       Are all “types” supposed to appear when selecting Repositories? It seems that if you select a repository, it should show you the collections only  OR signify the associated collection for each object/type in question

b.      When selecting a repository, the appropriate collections appear but “global” appears with results below the selected repository:

[cid:image001.png at 01D0B4C7.1826C530]

4.       Classifications appear to be duplicated:
[cid:image002.png at 01D0B4C7.1826C530]

5.       Components show [b] and [/b] OR [i] and [/i] in lists and headers:

[cid:image003.png at 01D0B4C7.1826C530]

6.       Can the Collections be sorted by Collection #/Identifier?

Thank you for any and all help regarding these issues.



Phillip Suda
Systems Librarian
Howard-Tilton Memorial Library
Tulane University
psuda1 at tulane.edu<mailto:psuda1 at tulane.edu>

Archivesspace_Users_Group mailing list
Archivesspace_Users_Group at lyralists.lyrasis.org<mailto:Archivesspace_Users_Group at lyralists.lyrasis.org>

Maura Carbone
Digital Initiatives Librarian
Brandeis University
Library and Technology Services
(781) 736-4659
415 South Street, (MS 017/P.O. Box 549110)
Waltham, MA 02454-9110
email: mauraa at brandeis.edu<mailto:mauraa at brandeis.edu>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20150702/a210c41f/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.png
Type: image/png
Size: 81711 bytes
Desc: image001.png
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20150702/a210c41f/attachment.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image002.png
Type: image/png
Size: 74842 bytes
Desc: image002.png
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20150702/a210c41f/attachment-0001.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image003.png
Type: image/png
Size: 9736 bytes
Desc: image003.png
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20150702/a210c41f/attachment-0002.png>

More information about the Archivesspace_Users_Group mailing list