<html dir="ltr">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=windows-1256">
<style type="text/css" id="owaParaStyle"></style>
</head>
<body style="word-wrap:break-word; font-size:14px; font-family:Tahoma,sans-serif; color:rgb(0,0,0)" fpstyle="1" ocsi="0">
<div style="direction: ltr;font-family: Tahoma;color: #000000;font-size: 10pt;"><span style="font-family: Tahoma; font-size: 13.3333px;">Hi Chris, Joshua,</span>
<div style="font-family: Tahoma; font-size: 13.3333px;"><br>
</div>
<div style="font-family: Tahoma; font-size: 13.3333px;">Yup, everyone is using their own stuff. I confirmed it happening with the admin account, too. 11 minutes after the last page refresh, it was okay and I navigated. 11 minutes after that, I had a backend
 session not found error. </div>
<div style="font-family: Tahoma; font-size: 13.3333px;"><br>
</div>
<div style="font-family: Tahoma; font-size: 13.3333px;">Load balancing in our case is very simple and through nginx to one of two application servers. There's 12gb per server. Staff is only on server 1. There's a mysql backend server used by both. Interestingly,
 I've only heard the complaint with one instance so far - although perhaps the others just haven't seen sufficient use yet. </div>
<div style="font-family: Tahoma; font-size: 13.3333px;"><br>
</div>
<div style="font-family: Tahoma; font-size: 13.3333px;">~Patrick</div>
<div style="font-family: Times New Roman; color: #000000; font-size: 16px">
<hr tabindex="-1">
<div id="divRpF915825" style="direction: ltr;"><font face="Tahoma" size="2" color="#000000"><b>From:</b> archivesspace_users_group-bounces@lyralists.lyrasis.org [archivesspace_users_group-bounces@lyralists.lyrasis.org] on behalf of Joshua D. Shaw [Joshua.D.Shaw@dartmouth.edu]<br>
<b>Sent:</b> Wednesday, January 13, 2016 12:25 PM<br>
<b>To:</b> Archivesspace Users Group<br>
<b>Subject:</b> Re: [Archivesspace_Users_Group] Backend Session Not Found<br>
</font><br>
</div>
<div></div>
<div>
<div>
<div>Hi all-</div>
<div><br>
</div>
<div>We typically experience the same warning/error at Dartmouth. In fact I've rarely, if ever, seen the "session expired due to inactivity" and naively assumed that the "Backend session not found"
<b>was</b> the message for expiration due to inactivity. Our setup is also clustered and we are only using the staff interface at this point - the public interface is turned off. Our clustering setup is as shown below.</div>
<div><br>
</div>
<div>One extra wrinkle is that we are currently using our in-house developed SSO plugin (<a href="https://github.com/dartmouth-dltg/aspace-omniauth-cas" target="_blank">https://github.com/dartmouth-dltg/aspace-omniauth-cas</a>) for authentication, but I'm fairly
 certain I saw the same message when we were running against LDAP authentication.</div>
<div><br>
</div>
<div>Joshua</div>
<div><br>
</div>
<div>
<div>Setup details with some obfuscation for security.</div>
<div><br>
</div>
<div>
<div>-          ArchivesSpace version: 1.3</div>
<div>-          Java version: 1.7.0_85-b15</div>
<div>-          CPU cores: 4 cores (each server)</div>
<div>-          Memory: 36gb (each server)</div>
</div>
<div><br>
</div>
<div style="font-family:Tahoma; font-size:medium"><font face="Tahoma,sans-serif">At the top level, clients connection for our hardware load balancer, Big-IPs F5. The F5 terminates SSL and sends HTTP traffic to one of four servers running Oracle HTTP Server
 (OHS), which is essentially Apache. Two of these servers also run the ArchivesSpace application. OHS is configured to send the HTTP traffic to the two application servers.</font></div>
<div><br>
</div>
<div><img src="cid:356CD593-8641-40EB-AAF1-CC107B912C42" type="image/png" height="337.500000" width="508.500000"></div>
</div>
<div>
<div id="MAC_OUTLOOK_SIGNATURE"></div>
</div>
</div>
<div><br>
</div>
<span id="OLK_SRC_BODY_SECTION">
<div style="font-family:Calibri; font-size:12pt; text-align:left; color:black; border-bottom:medium none; border-left:medium none; padding-bottom:0in; padding-left:0in; padding-right:0in; border-top:#b5c4df 1pt solid; border-right:medium none; padding-top:3pt">
<span style="font-weight:bold">From: </span>Chris Fitzpatrick<br>
<span style="font-weight:bold">Reply-To: </span>Archivesspace Users Group<br>
<span style="font-weight:bold">Date: </span>Wednesday, January 13, 2016 at 12:16 PM<br>
<span style="font-weight:bold">To: </span>"Archivesspace Users Group [<a href="mailto:archivesspace_users_group@lyralists.lyrasis.org" target="_blank">archivesspace_users_group@lyralists.lyrasis.org</a>]"<br>
<span style="font-weight:bold">Subject: </span>Re: [Archivesspace_Users_Group] Backend Session Not Found<br>
</div>
<div><br>
</div>
<div><style type="text/css" style="">
<!--
p
        {margin-top:0;
        margin-bottom:0}
-->
</style>
<div dir="ltr">
<div id="divtagdefaultwrapper" style="font-size:12pt; color:#000000; background-color:#FFFFFF; font-family:Calibri,Arial,Helvetica,sans-serif">
<p><br>
</p>
<p>Hi Patrick,</p>
<p><br>
</p>
<p>Hm, that is odd. So, the stuff UI is always via the same URL for everyone? <br>
</p>
<p>Also, it's not multiple people using the same login information ( therefore someone might be logging out? Sorry, just a sanity check question .. )
<br>
</p>
<p>b,chris. <br>
</p>
<p><br>
</p>
<div id="Signature">
<div name="divtagdefaultwrapper" style="font-family:Calibri,Arial,Helvetica,sans-serif; font-size:; margin:0">
<div class="BodyFragment"><font size="2">
<div class="PlainText">Chris Fitzpatrick | <font size="2">Developer, ArchivesSpace</font><br>
Skype: chrisfitzpat  | Phone: 918.236.6048<br>
<a href="http://archivesspace.org/" target="_blank">http://archivesspace.org/</a><br>
</div>
</font></div>
</div>
</div>
<br>
<br>
<div style="color:rgb(0,0,0)">
<hr tabindex="-1" style="display:inline-block; width:98%">
<div id="divRplyFwdMsg" dir="ltr"><font face="Calibri,sans-serif" color="#000000" style="font-size:11pt"><b>From:</b>
<a href="mailto:archivesspace_users_group-bounces@lyralists.lyrasis.org" target="_blank">
archivesspace_users_group-bounces@lyralists.lyrasis.org</a> <<a href="mailto:archivesspace_users_group-bounces@lyralists.lyrasis.org" target="_blank">archivesspace_users_group-bounces@lyralists.lyrasis.org</a>> on behalf of Flanagan, Patrick <<a href="mailto:PJFlanagan@ship.edu" target="_blank">PJFlanagan@ship.edu</a>><br>
<b>Sent:</b> Wednesday, January 13, 2016 5:58 PM<br>
<b>To:</b> Archivesspace Users Group [<a href="mailto:archivesspace_users_group@lyralists.lyrasis.org" target="_blank">archivesspace_users_group@lyralists.lyrasis.org</a>]<br>
<b>Subject:</b> [Archivesspace_Users_Group] Backend Session Not Found</font>
<div> </div>
</div>
<div>
<div style="direction:ltr; font-family:Tahoma; color:#000000; font-size:10pt">Good morning,
<div><br>
</div>
<div>I have a question that isn't migration related for once. Users on one of my instances in a clustered setup are seeing "Your backend session was not found" periodically, which doesn't appear to be the error message related to an ordinary timeout (that would
 have been "Your session expired due to inactivity")</div>
<div><br>
</div>
<div>Are there any common causes for this? The setup is clustered, but the staff interface explicitly uses only one install on one machine. That is to say the public interface is load-balanced, but any usage on the staff side is always with the same server.</div>
<div><br>
</div>
<div>Thanks for your time,</div>
<div><br>
</div>
<div>~Patrick Flanagan</div>
<div>KLN Applications Administrator</div>
<div>Keystone Library Network Hub</div>
</div>
</div>
</div>
</div>
</div>
</div>
</span></div>
</div>
</div>
</body>
</html>