[Archivesspace_Users_Group] Auto formatting with dates on Accession CSV import template

Heidi R. Pettitt Heidi.Pettitt at loras.edu
Thu May 4 18:40:11 EDT 2023

I've been copying and pasting a lot between Word and Excel this week, so I know your pain. My inefficient solution to this issue for me has been adding an extra character to the beginning of the date string and then using the RIGHT() function to pull the date without the beginning character and use paste value to replace the cell. So far, it's working and takes a little less time than retyping everything.

I hope this helps,


Director of the Center for Dubuque History
Access Services & Special Collections Librarian

Library & Center for Dubuque History
Miller Academic Resource Center 154
1450 Alta Vista
Dubuque, IA 52001
Meet With Me!<https://loras.libcal.com/appointments>

From: archivesspace_users_group-bounces at lyralists.lyrasis.org <archivesspace_users_group-bounces at lyralists.lyrasis.org> On Behalf Of Sarah Shepherd
Sent: Tuesday, May 2, 2023 8:10 AM
To: archivesspace_users_group at lyralists.lyrasis.org
Subject: [Archivesspace_Users_Group] Auto formatting with dates on Accession CSV import template


I'm having some difficulty with the Accession CSV template autoformatting my dates into the incorrect format for ArchivesSpace. It is only a problem with a single date. For example, I will put in 1920-04-29 which is the proper ArchivesSpace format for date_1_begin. The Accession CSV template then autocorrects it to be 4/29/1920 turning the cell format into a Date format instead of the standard General format. When I switch the cell format back to General it turns the number into 7425. When I put the correct date (1920-04-29) back in, it again auto formats the cell to a Date format, so it goes back to 4/29/1920. Bizarrely, it does not do the same for another record which has 1865-11-27 as date_1_begin.

I tried to look up how to stop this auto formatting but have not found anything. I even tried setting the date format to English (South Africa) which has a date format of 1920-04-29, but when I save the document, it got rid of all the formatting and reverts to 4/29/1920. I have tried importing the template without saving so that it keeps the 1920-04-29 date format (set to the English (South Africa)) and it gives an error (#<ArgumentError: invalid byte sequence in UTF-8&gt) which I saw on a different post meant that there is incorrect formatting on the template. It goes without saying that when I tried to import the template with the date as 4/29/1920, it also did not work (though interestingly, returning the same error (#<ArgumentError: invalid byte sequence in UTF-8&gt) instead of an incorrect date error).

In another weird twist, the template does not get the (#<ArgumentError: invalid byte sequence in UTF-8&gt) when accession_accession_date autoformats its cell to date and ArchivesSpace can also deal with the import just fine with the incorrect date format of 3/29/2023 turning it into 2023/03/29 in the record in ArchivesSpace. Why the difference?

That was a lot of information, but as you can see, I've done some troubleshooting to try to figure out the issue and have only become more confused!

Has anyone else run into this issue with single dates? Are there any work arounds besides giving up on single dates when importing?

Grateful for any help,

Sarah H. Shepherd
Scottish Rite Masonic Museum and Library
33 Marrett Road | Lexington, MA 02421
Phone: 781-457-4129 | Email: sshepherd at srmml.org<mailto:sshepherd at srmml.org>

CONFIDENTIALITY NOTICE: This email, including any attachments, is the property of Loras College. The information may be legally privileged and/or confidential and is intended solely for the use of the addressee. If you are not the intended recipient be advised that any unauthorized disclosure, copying, distribution or use of the contents herein is strictly prohibited. If you have received this message in error, please notify the sender immediately and destroy all electronic and hard copies of the communication, including attachments.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20230504/2d7986a6/attachment.html>

More information about the Archivesspace_Users_Group mailing list