[Archivesspace_Users_Group] Locations List Providing Not-Even Close Results?

Benn Joseph benn.joseph at northwestern.edu
Mon May 24 13:01:46 EDT 2021

At one point we tried to make the below adjustments to get our locations to show up in a rational way, but it didn’t work that well and now I’m wondering if we even did it right since we’re still struggling with them. But, I can’t seem to find any of the previous messages describing what to do—can anyone provide a quick rehash?


From: archivesspace_users_group-bounces at lyralists.lyrasis.org <archivesspace_users_group-bounces at lyralists.lyrasis.org> On Behalf Of Trevor Thornton
Sent: Wednesday, March 31, 2021 8:41 AM
To: Archivesspace Users Group <archivesspace_users_group at lyralists.lyrasis.org>
Subject: Re: [Archivesspace_Users_Group] Locations List Providing Not-Even Close Results?

This issue keeps coming up and the solution usually involves adjusting the "default sort column" and "default sort direction" in the appropriate section in the settings (in this case it would be "Location Profile Browse Columns" I think). We had this same problem and adjusting these values worked for us, but other people have reported that it didn't.

There are 3 levels of settings (Global, Repository and User) that should override one another. Here's what it says in the User Guide:
Global Preferences – Edit these values to set your system-wide preferences. These values can be overridden by repository default or by your own preferences for a repository.
Repository Preferences – Edit these values to set your user preferences for this repository. These values can be overridden by user preferences.
User Preferences – Edit these values to set user preference defaults for the current repository. These values cannot be overridden.
In my experience, this doesn't work as smoothly as advertised, but in theory this is how it should work.

Given how frequently this problem has been reported, and the impact it has on people's workflows, I think this issue (using preference settings to adjust sort order in lists) is in desperate need of documentation.

On Wed, Mar 31, 2021 at 8:43 AM ABNEY, ANN C <aabney at mailbox.sc.edu<mailto:aabney at mailbox.sc.edu>> wrote:
Morning all -

We’re using 2.8.1 and recently I’ve been having trouble adding locations. Our numbering convention is Row: #, Compartment: #, Shelf: #. In the manage top containers tab for a specific resource, usually I’ll search to add a location with that format. But lately, even if I put the full name of the location (with repository, floor, etc.) I’m getting lots of extraneous results.

For example, I was searching for “Row: 61, Compartment: 6, Shelf: 1” I got results including from Row 2, Compartment 1, Shelf 6, and then a whole list of every shelf in Row 61 from Compartments 1-4 until the list cut off. If I search via browse, I get the same results and usually have to click through to the second page. As I said before, this even happens if I copy word for word a previous location already linked.

Am I searching wrong? Is it a bug? I haven’t had this problem in past iterations so I have no idea what’s going on.


Ann Abney, CA
Special Projects Archivist
South Carolina Political Collections
University of South Carolina Libraries
aabney at mailbox.sc.edu<mailto:aabney at mailbox.sc.edu>

Archivesspace_Users_Group mailing list
Archivesspace_Users_Group at lyralists.lyrasis.org<mailto:Archivesspace_Users_Group at lyralists.lyrasis.org>

Trevor Thornton
Applications Developer, Digital Library Initiatives
North Carolina State University Libraries
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20210524/010bfdb1/attachment.html>

More information about the Archivesspace_Users_Group mailing list