[Archivesspace_Users_Group] Updating archivesspace and plugin results in two plugin buttons

Tam Mayeshiba tam.mayeshiba at wisc.edu
Tue Apr 27 11:55:56 EDT 2021

Hello ArchivesSpace User Group,

(Apologies if this message double-posts. I didn't see my previous message appear on the mailing list, so I am sending it again.)

I am having an issue where duplicate plugin buttons are showing up in the Resource plugin bar.

This happens while upgrading ArchivesSpace from version 2.7.0 to either version 2.8.1 or 3.0.0-RC2. The plugin is the aspace-import-excel plugin.

When I upgrade ArchivesSpace, I get an error message

[!] There was an error parsing `Gemfile`: You cannot specify the same gem twice with different version requirements.

You specified: rubyXL (~> 3.4, >= 3.4.9) and rubyXL (= 3.3.29). Bundler cannot continue.

I can fix this error message by editing the aspace-import-excel plugin's Gemfile to require rubyXL ~>3.4, >=3.4.9. This is true of either plugin version 2.1.17 or version 3.0.4.

However, once I get ArchivesSpace running, the plugin bar for a Resource record shows two of the aspace-import-excel plugin buttons, "Load via Spreadsheet"

I have also tried to remove the plugin entirely from config.rb and restart, but in that case, there is still a single "Load via Spreadsheet" button where I would expect there to be none.

Is there some kind of plugin cache or set of temporary files I should be clearing out? I tried clearing data/tmp, but is there somewhere else to look?


Tam Mayeshiba

Linux Systems Administrator

UW-Madison Library Technology Group

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20210427/884852aa/attachment.html>

More information about the Archivesspace_Users_Group mailing list