[Archivesspace_Users_Group] Installing digitization_work_order

Kara Hart kstrosch at wellesley.edu
Tue Apr 13 17:02:04 EDT 2021

Hi all, I've just tried installing the digitization_work_order plugin on my
test server (CentOS 7 with ArchivesSpace 2.7.0) and when initializing the
plugin got a Gem install error about the Ruby version (below).  Not sure
what to do with this.  Does this mean I need to install a newer version of
Will this have any other consequences on my server?  Thanks for any

Fetching: bundler-1.16.1.gem (100%)

Successfully installed bundler-1.16.1

1 gem installed

Don't run Bundler as root. Bundler can ask for sudo if it is needed, and

installing your bundle as root will break this application for all non-root

users on this machine.

Fetching gem metadata from http://rubygems.org/...

Resolving dependencies...

Using bundler 1.16.1

Fetching rubyzip 2.3.0

Installing rubyzip 2.3.0

Gem::InstallError: rubyzip requires Ruby version >= 2.4.

An error occurred while installing rubyzip (2.3.0), and Bundler

cannot continue.

Make sure that `gem install rubyzip -v '2.3.0'` succeeds before bundling.

In Gemfile:

  write_xlsx was resolved to 0.85.3, which depends on

    zip-zip was resolved to 0.3, which depends on


~~~ Kara S. Hart
Systems Librarian - Library & Technology Services
Wellesley College
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20210413/ad4c2509/attachment.html>

More information about the Archivesspace_Users_Group mailing list