[Archivesspace_Users_Group] Search Across Repositories and Get EAD XML - ArchivesSpace API

Corey Schmidt Corey.Schmidt at uga.edu
Tue Mar 10 08:29:09 EDT 2020

We will have to set up our OAI configuration, but haven’t looked into that process yet. I will keep this in mind moving forward. Thanks!

From: archivesspace_users_group-bounces at lyralists.lyrasis.org <archivesspace_users_group-bounces at lyralists.lyrasis.org> On Behalf Of Majewski, Steven Dennis (sdm7g)
Sent: Monday, March 9, 2020 12:43 PM
To: Archivesspace Users Group <archivesspace_users_group at lyralists.lyrasis.org>
Subject: Re: [Archivesspace_Users_Group] Search Across Repositories and Get EAD XML - ArchivesSpace API

I would also add that if you want the EAD, it may be simpler to access it from the OAI endpoint, but only if OAI is configured properly. Try downloading a resource using oai_ead metadata from the oai/sample page, to see if it’s configured properly and what the resource URLs will look like.

— Steve M.

On Mar 9, 2020, at 10:39 AM, Corey Schmidt <Corey.Schmidt at uga.edu<mailto:Corey.Schmidt at uga.edu>> wrote:

Dear ArchivesSpace Members,

Hello, my name is Corey Schmidt and I’m working as the ArchivesSpace Project Manager at the University of Georgia. I hope you all are doing well and having a good start to your week.

I have two questions about how to utilize the ArchivesSpace API. First, I want to use the Search across repositories<https://archivesspace.github.io/archivesspace/api/#search-across-repositories> API endpoint searching with the resource identifier and take the results to get the URI for that resource. How do I structure my call to the API using the ASnake client (in python)? I have tried the following code with response 400 returned:


Second, I want to download an EAD xml file directly from the API using this endpoint: Get an EAD representation of a Resource<https://archivesspace.github.io/archivesspace/api/#get-an-ead-representation-of-a-resource>XML. How do I specify where the EAD xml file saves to? I’m not even sure if it is saving anywhere on my computer. However, my requests are successful, generating a 200 response. I tried turning the response into json (using ASnake’s .json()) and writing it, but I keep getting a JSONDecodeError. This is my request:

     request_ead = client.get('repositories/5/resource_descriptions/5734.xml?include_unpublished=false&include_daos=true&numbered_cs=true&print_pdf=false&ead3=false')

Any help would be greatly appreciated!



Corey Schmidt
ArchivesSpace Project Manager | University of Georgia Libraries
Email: Corey.Schmidt at uga.edu<mailto:Corey.Schmidt at uga.edu>
Phone: +1-706-542-8151

Archivesspace_Users_Group mailing list
Archivesspace_Users_Group at lyralists.lyrasis.org<mailto:Archivesspace_Users_Group at lyralists.lyrasis.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20200310/026836d5/attachment.html>

More information about the Archivesspace_Users_Group mailing list