[Archivesspace_Users_Group] aspace-oauth installation

Zhang, Bin bzhang at csus.edu
Thu Aug 22 15:24:38 EDT 2019

Thanks Francis.  It turns out the problem was with the proxy server set up on the server.  After fixing that problem, I was able to install and configure CAS and it worked!

One question: can I map additional attributes like with the ldap authentication module?  I tried this:

fetch_raw_info: ->(s, o, t, user_info) {
        { email: "#{user_info['UserPrincipalName']}",
          name: "#{user_info['DisplayName']}"

Email was mapped, but the DisplayName didn't show up for some reason...


Bin Zhang
Digital Information Services Librarian
Library Systems & IT Services, University Library
California State University, Sacramento
+1 (916) 278-5664 | bzhang at csus.edu
Zoom: https://csus.zoom.us/my/bzhang

On 8/22/19, 3:41 AM, "archivesspace_users_group-bounces at lyralists.lyrasis.org on behalf of Francis Kayiwa" <archivesspace_users_group-bounces at lyralists.lyrasis.org on behalf of kayiwa at princeton.edu> wrote:

    On 8/21/19 6:38 PM, Zhang, Bin wrote:
    > I submitted this to the aspace-oauth repo Issues, but haven’t heard
    > anything.  I am trying it here, hopefully someone can give me some advice:
    > Tried to install on ubuntu 16.04 LTS, AS 2.6.0:
    > |/data/archivesspace$ ./scripts/initialize-plugin.sh aspace-oauth|
    > |ERROR:  While executing gem ... (Net::HTTPServerException)|
    > |    403 "Forbidden"|
    > |Gem::GemNotFoundException: can't find gem bundler (>= 0.a)|
    This error above suggests that bundler is not installed on the OS or the
    user archivesspace runs as.
    Not knowing how you install software on your Operating System the link
    below would help.

More information about the Archivesspace_Users_Group mailing list