[Archivesspace_Users_Group] Rails help for font-awesome classes ?

Majewski, Steven Dennis (sdm7g) sdm7g at virginia.edu
Tue Feb 20 19:22:08 EST 2018

I expect that this has something to do with how stylesheet assets are compiled in Rails, but can anyone explain it to me ? 

Running in development mode, testing changes to digital object views with IIIF plugin, I noticed I was not seeing the font-awesome icon for the 'fa-file-image-o’ class styles.

 <i class="fa fa-file-image-o fa-4x"></i><br/>

After poking around in the browser console and stylesheets, I discovered that by removing the “-o” suffix, it worked again:

 <i class="fa fa-file-image fa-4x"></i><br/>

Initially, I thought this may have been a bug introduced in some recent changes to v2.3.0, but git log didn’t show any likely changes and when I deployed my plugin changes to production, they icons were NOT displayed. 

When I added the “-o” suffix back, they worked on production, but failed running in development. 
( development = ./build/run public:devserver ) 

The badges on the public resource pages use “fa-book” class for citation badge and “fa-file-pdf-o” for print badge.
Both of those display properly on production site, but the print badge is missing in development mode. 

BTW: I was attempting to add appropriate icons switched by d_file[‘material’] 

— Steve Majewski

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20180221/cad0c7ef/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 6091 bytes
Desc: not available
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20180221/cad0c7ef/attachment.bin>

More information about the Archivesspace_Users_Group mailing list