[Archivesspace_Users_Group] Accessions Import Error id_0

Zachary Adams Zachary.Adams at brooklynmuseum.org
Mon Dec 17 14:18:06 EST 2018

Hi All,

Fairly new to using ASpace, so you have my sincere apologies if this question has been answered previously for the group, or if I missed the best resource to find an answer.

I'm importing a .csv of accession records and keep getting the error message:

id_0: That ID is already in use.

Problem creating 'Records of the Finance Department': id_0 That ID is already in use

My understanding from the user manual and screencasts that I've watched so far is that only the accession ID needs to be unique, not the accession title (this upload has a number of records with identical titles, but all have different accession IDs). We are using a pretty standard multi-part accession number format of YYYY-0001-0001, tracking sequentially each accession throughout a given year. So on the import template, we have the accession numbers broken up in 'accession_number_1', 'accession_number_2', and 'accession_number_3', with 'accession_number_4' left blank. Though this adds up to an overall unique identifier for any given record, it clearly results in the 'accession_number_1' field being identical for all the accessions in the same year, including a few records with identical titles as well. Is that what's triggering the error?

I double checked that my 'accession_number' fields are all unique when all four fields are combined, and they are. I also tried removing the specific records cited in the error above from the .csv and attempted importing again, but the import produces the same error only now citing a different duplicate title.

Any thoughts on how to proceed?

Many thanks for reading.


Zach Adams
Project Archivist
Brooklyn Museum
200 Eastern Parkway, Brooklyn, NY 11238-6052


More information about the Archivesspace_Users_Group mailing list