[Archivesspace_Users_Group] Archon -> ArchivesSpace Migration Failure Message

Christine Di Bella christine.dibella at lyrasis.org
Mon Apr 9 15:53:18 EDT 2018

Hello Austin and Andrea,

I’m going to put a tech support ticket in for you on this. (You’ll see another message about that directly to you in a minute.) The tech folks should be able to help you through the process of using the Archon migration tool. Once you get it worked out, it’d be great if you’d share the solution back to the listserv.


Christine Di Bella
ArchivesSpace Program Manager
christine.dibella at lyrasis.org<mailto:christine.dibella at lyrasis.org>
800.999.8558 x2905
cdibella13 (Skype)


From: archivesspace_users_group-bounces at lyralists.lyrasis.org <archivesspace_users_group-bounces at lyralists.lyrasis.org> On Behalf Of Austin Royal
Sent: Monday, April 9, 2018 2:46 PM
To: Archivesspace Users Group <archivesspace_users_group at lyralists.lyrasis.org>
Subject: Re: [Archivesspace_Users_Group] Archon -> ArchivesSpace Migration Failure Message


I am assisting Andrea on this process. The credentials do indeed belong to an account with administrative permissions for this Archon instance, and are valid/correct. The link to the Archon source is also valid (we've tried variations with protocol and paths just to make sure) as the migration tool proceeds with the first bit of authentication after successfully connecting to the Archon source, but ultimately fails and presents the error previously mentioned.

I managed to nab a copy of the log before it spits out the error almost instantly. Here's what it says:

Administrator authenticated ...
Finding Accession Records Repositories ...
Getting records for: ?p=core/accessions&batch_start=1
No accessions found ...

I hope this helps, thank you.

On Mon, Apr 9, 2018 at 11:53 AM, Edgar Garcia <edgar-garcia at northwestern.edu<mailto:edgar-garcia at northwestern.edu>> wrote:

The error seems to point to here: https://github.com/archivesspace/archon-migration/blob/v2.3.x/src/org/nyu/edu/dlts/utils/ASpaceCopyUtil.java#L349, assuming you are using the 2.3.x version of the migrator.

It could suggest that it did not successfully connect to your Archon instance and thus did not return any records causing the Null Pointer Exception. Ensure that the Archon user/password combo has administrator privileges, and the archon source is the correct URL.

Edgar Garcia
Senior Software Developer
Discovery Platform Services
IT Infrastructure
Northwestern University Libraries
Northwestern University
Evanston, IL 60208
From: <archivesspace_users_group-bounces at lyralists.lyrasis.org<mailto:archivesspace_users_group-bounces at lyralists.lyrasis.org>> on behalf of "abriggs at mcdaniel.edu<mailto:abriggs at mcdaniel.edu>" <abriggs at mcdaniel.edu<mailto:abriggs at mcdaniel.edu>>
Reply-To: "archivesspace_users_group at lyralists.lyrasis.org<mailto:archivesspace_users_group at lyralists.lyrasis.org>" <archivesspace_users_group at lyralists.lyrasis.org<mailto:archivesspace_users_group at lyralists.lyrasis.org>>
Date: Monday, April 9, 2018 at 9:19 AM
To: "archivesspace_users_group at lyralists.lyrasis.org<mailto:archivesspace_users_group at lyralists.lyrasis.org>" <archivesspace_users_group at lyralists.lyrasis.org<mailto:archivesspace_users_group at lyralists.lyrasis.org>>
Subject: [Archivesspace_Users_Group] Archon -> ArchivesSpace Migration Failure Message


We are attempting to migrate from Archon Version 3.21 rev-2.1 to ArchivesSpace installation V2.3.0 but we are encountering this error. We have followed up to step 5c and 5d in the Archon Migration Tool Instructions and were met with the following error.

Can anyone help us interpret this error and figure out where to move forward?


Unrecoverable exception, migration stopped ...

Current Record Type:
Record Identifier :

at org.nyu.edu.dlts.utils.ASpaceCopyUtil.copyRepositoryRecords(ASpaceCopyUtil.java:349)
at org.nyu.edu.dlts.dbCopyFrame$1.run(dbCopyFrame.java:229)
at java.base/java.lang.Thread.run(Unknown Source)


Andrea J. Briggs
Archivist & Special Collections Librarian
McDaniel College Archives<https://urldefense.proofpoint.com/v2/url?u=http-3A__lib.hoover.mcdaniel.edu_archives-2Dhome&d=DwMFAw&c=yHlS04HhBraes5BQ9ueu5zKhE7rtNXt_d012z2PA6ws&r=qL9mtrzN5YM9JLty72jmSvS2xXL_z4-MUTBxVwpL3SM&m=bUK6YT2V4xrm0UjoEnVreiG9AmZO4mkmABIXd-vIf0U&s=wPTaiiCQPz9PFTqGFM_U77uFbFuxSuCawtDIIQvoUkw&e=>
2 College Hill, Westminster, MD 21157
abriggs at mcdaniel.edu<mailto:abriggs at mcdaniel.edu>

Archivesspace_Users_Group mailing list
Archivesspace_Users_Group at lyralists.lyrasis.org<mailto:Archivesspace_Users_Group at lyralists.lyrasis.org>

Austin Royal
Computer Science Major & Art Minor
McDaniel College Class of 2018
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20180409/d210b6c8/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.jpg
Type: image/jpeg
Size: 6608 bytes
Desc: image001.jpg
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20180409/d210b6c8/attachment.jpg>

More information about the Archivesspace_Users_Group mailing list