[Archivesspace_Users_Group] Subject Heading Plugin not working properly 1.4.2

Karen Miller k-miller3 at northwestern.edu
Fri Jun 16 14:57:04 EDT 2017

Hi, Candace.

I can't help on the plugin operational issue, but I can offer a caveat about using the plugin for LCSH. This plugin has (until very recently) worked well for us at NUL for importing Agent records from LCNAF, but we have never used it to import Subject records. And, as Steve pointed out, the import from OCLC is unreliable.

When a Subject is imported using this plug-in, individual Subject records are created for the preferred term (the MARC 150 field in the authority record) as well as for each of the non-preferred terms (the MARC 450 fields in the authority record, i.e., references). For example, an LCSH record with 4 non-preferred terms will be imported as 5 Subject records, one for the preferred term and one for each of the non-preferred terms, with no indication in the records for the non-preferred terms that they are references and should not be assigned, as well as no indication of the preferred term with which they are associated. This is almost certainly not what your archivists or catalogers want.

While the import of Name Authority File (LCNAF) records correctly places non-preferred names in the Agent record for the preferred name designated as references, the import of LCSH records operates differently and would wreak havoc on the use of Subject records.

I understand that Yale is undertaking a project to update the plug-in and hopes to change the functionality so that only the preferred Subject term is imported, but until then, I can't recommend using it.


Karen D. Miller
Monographic Cataloger/Metadata Specialist
Northwestern University Libraries
Northwestern University
1970 Campus Drive
Evanston, IL 60208
k-miller3 at northwestern.edu

From: archivesspace_users_group-bounces at lyralists.lyrasis.org [mailto:archivesspace_users_group-bounces at lyralists.lyrasis.org] On Behalf Of Maurice, Candace A
Sent: Friday, June 16, 2017 1:39 PM
To: Archivesspace Users Group <archivesspace_users_group at lyralists.lyrasis.org>
Subject: Re: [Archivesspace_Users_Group] Subject Heading Plugin not working properly 1.4.2

Hi Steve,

I tried to implement the patch, but still no luck. My file on line 71 is different than in the patch you provided  (see function below).

def search(query, page, records_per_page)
    uri = URI(@base_url)
    start_record = calculate_start_record(page, records_per_page)
    params = default_params.merge('q' => [query.to_s, @scheme],
                                  'count' => records_per_page,
                                  'start' => start_record)

    uri.query = URI.encode_www_form(params)

    response = Net::HTTP.get_response(uri)

    if response.code != '200'
      raise OpenSearchException.new("Error during OpenSearch search: #{response.body}")

    results = OpenSearchResultSet.new(response.body, query)

    results.entries.each do |entry|
      marc_uri = URI("#{entry['uri']}.marcxml.xml")
      response = Net::HTTP.get_response(marc_uri)
      if response.code != '200'
        raise OpenSearchException.new("Error during OpenSearch search: #{response.body}")

      entry['xml'] = response.body.force_encoding("iso-8859-1").encode('utf-8')



From: <archivesspace_users_group-bounces at lyralists.lyrasis.org<mailto:archivesspace_users_group-bounces at lyralists.lyrasis.org>> on behalf of "Majewski, Steven Dennis (sdm7g)" <sdm7g at eservices.virginia.edu<mailto:sdm7g at eservices.virginia.edu>>
Reply-To: Archivesspace Users Group <archivesspace_users_group at lyralists.lyrasis.org<mailto:archivesspace_users_group at lyralists.lyrasis.org>>
Date: Thursday, June 15, 2017 at 12:26 PM
To: Archivesspace Users Group <archivesspace_users_group at lyralists.lyrasis.org<mailto:archivesspace_users_group at lyralists.lyrasis.org>>
Subject: Re: [Archivesspace_Users_Group] Subject Heading Plugin not working properly 1.4.2

It appears to be no longer working in any version.
I believe loc has changed the API for the service slightly. Need to investigate further.
But trying to reverse engineer the parameters from inspecting the difference in the params used in the web page search vs. what's embedded in LCNAF plugin, I tried this change, which appears to work for me:

diff --git a/plugins/lcnaf/frontend/models/opensearcher.rb b/plugins/lcnaf/frontend/models/opensearcher.rb
index 9391ab5..37e2813 100644
--- a/plugins/lcnaf/frontend/models/opensearcher.rb
+++ b/plugins/lcnaf/frontend/models/opensearcher.rb
@@ -14,7 +14,7 @@ class OpenSearcher

   def initialize(base_url, scheme )
     @base_url = base_url
-    @scheme = scheme
+    @scheme = "cs:" + scheme

@@ -71,7 +71,7 @@ class OpenSearcher
                                   'start' => start_record)

     uri.query = URI.encode_www_form(params)
+    p uri
     results = HTTPRequest.new.get(uri) do |response|
       if response.code != '200'
         raise OpenSearchException.new("Error during OpenSearch search: #{response.body}")

( The other OCLC search has always been unreliable - it's a test site and not a supported service. )

- Steve Majewski

On Jun 15, 2017, at 12:07 PM, Maurice, Candace A <cmaurice at tulane.edu<mailto:cmaurice at tulane.edu>> wrote:

Hello All,

We are on version 1.4.2 and we have had a user report that the subject heading plugin is not returning results for either LCNAF or LCSH (OCLC works, however). The user doesn't receive any error messages when using the plugin,  but tried typing in known subject headings for the Library Of Congress and it's still not returning results. I checked the  Background jobs and logs and there are not error messages. I also went to the LOC website and all appears to be fine when searching subject headings on their site.

Has anyone else experienced a similar issue? Can you point me in the right direction for resolving this issue?



Candace Maurice
Web Developer
Howard-Tiltion Memorial Library
Tulane University
cmaurice at tulane.edu<mailto:cmaurice at tulane.edu>
Archivesspace_Users_Group mailing list
Archivesspace_Users_Group at lyralists.lyrasis.org<mailto:Archivesspace_Users_Group at lyralists.lyrasis.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20170616/19a2b258/attachment.html>

More information about the Archivesspace_Users_Group mailing list