[Archivesspace_Users_Group] AS upgrade advice needed

Hambleton, John S jhamblet at nmu.edu
Wed Jan 11 12:52:27 EST 2017

I’m in this situation right now, that is, 1.4.2 in production, cloned production database to TEST,
ran the setup-database script, and started up archivesspace 1.5.2. I did see in the archivesspace.out
log: Completed: existing containers have been migrated to the new container model.
So far so good. Then the indexer started, and immediately I saw:
“Error: Some library (perhaps JRuby) was built with a later JVM version.
Please use libraries built with the version you intend to use or an earlier one.”

OK, I tried updating java on the server (CentOS 6):
From: java version "1.6.0_39"
To:      java version "1.8.0_102"

Restart archivesspace, indexer started running!
The only thing I’m not real sure of though, is how long it takes for the indexer to finish.
I guess it would depend on how much data there is to index. If anyone has an idea of how
to tell when the indexer has indexed everything, much obliged.

John H

From: archivesspace_users_group-bounces at lyralists.lyrasis.org [mailto:archivesspace_users_group-bounces at lyralists.lyrasis.org] On Behalf Of Majewski, Steven Dennis (sdm7g)
Sent: Wednesday, January 11, 2017 11:38 AM
To: Archivesspace Users Group <archivesspace_users_group at lyralists.lyrasis.org>
Subject: Re: [Archivesspace_Users_Group] AS upgrade advice needed

It’s always worked for me ( up to 1.5.1 - I haven’t tried 1.5.2 release yet ) to clone production database to test, run the setup-database script and start up archivesspace. 1.5.x startup takes quite a bit longer as it migrates to the new data model. So you shouldn’t have to install a test of 1.4.2 first. There’s also no reason not to go straight to 1.5.2.

On Jan 11, 2017, at 11:15 AM, Cobourn, Alston <Alston.Cobourn at tamucc.edu<mailto:Alston.Cobourn at tamucc.edu>> wrote:

Dear all,

I'm hoping some one can give me upgrade advice.  We are currently using AS 1.4.2.  Would it be best to upgrade straight from 1.4.2 to 1.5.2 or would it be best to upgrade incrementally?

Relatedly, I'd like to do the upgrade first on a test server to make sure the shift in the underlying data model doesn't cause a huge problem for our data.  We do not however currently have a test instance.  Could I request IT set up a 1.5.2 test instance and import our data straight into that to answer this question or do I really need to have them set up a 1.4.2 test instance, import our data into that, and then upgrade that to 1.5.2.  Thank you!


Alston Cobourn
Processing and Digital Assets Archivist
Texas A&M-Corpus Christi
alston.cobourn at tamucc.edu<mailto:alston.cobourn at tamucc.edu>
Archivesspace_Users_Group mailing list
Archivesspace_Users_Group at lyralists.lyrasis.org<mailto:Archivesspace_Users_Group at lyralists.lyrasis.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20170111/aa3b8e6e/attachment.html>

More information about the Archivesspace_Users_Group mailing list