[Archivesspace_Users_Group] "View Published" not resolving correct web address

Teitelbaum, Jesse jteitelbaum at pabmc.net
Wed Feb 1 10:40:55 EST 2017

Thanks much!  Works well now.


From: archivesspace_users_group-bounces at lyralists.lyrasis.org [mailto:archivesspace_users_group-bounces at lyralists.lyrasis.org] On Behalf Of Mark Cooper
Sent: Wednesday, February 01, 2017 10:30 AM
To: archivesspace_users_group at lyralists.lyrasis.org
Subject: Re: [Archivesspace_Users_Group] "View Published" not resolving correct web address

Hi Jesse,

There are two settings in the config.rb file (in the config folder) that apply here:


For the url to your staff interface


For the url to your public interface

Update those and restart ArchivesSpace.



Mark Cooper
Technical Lead, Hosting and Support
email: mark.cooper at lyrasis.org<mailto:mark.cooper at lyrasis.org>
skype: mark_c_cooper
From: archivesspace_users_group-bounces at lyralists.lyrasis.org<mailto:archivesspace_users_group-bounces at lyralists.lyrasis.org> <archivesspace_users_group-bounces at lyralists.lyrasis.org<mailto:archivesspace_users_group-bounces at lyralists.lyrasis.org>> on behalf of Teitelbaum, Jesse <jteitelbaum at pabmc.net<mailto:jteitelbaum at pabmc.net>>
Sent: Wednesday, February 1, 2017 7:07:52 AM
To: archivesspace_users_group at lyralists.lyrasis.org<mailto:archivesspace_users_group at lyralists.lyrasis.org>
Subject: [Archivesspace_Users_Group] "View Published" not resolving correct web address

After doing a test migration from ARCHON to AS (1.4.2), when I am logged into the staff interface, I can edit a RESOURCE.  I have the ability then to click on VIEW PUBLISHED to see what the record would look like on the public site.  But when I click on it, I get an error stating "This page cannot be opened."  I tried it with several different records with the same result.

Now, I can open the regular public interface separately and view the record, but to have that logged-in feature not working is concerning.

It appears that it is not resolving the correct web address. When I look in the address bar when I click on View Published, it is using localhost:8081 instead of my test site, bmc-asmigrate:8081. I don't know if this is a support or a setup issue. Has this been fixed in later release (remember, this is version 1.4.2) or if it is a setup issue?

[cid:image001.jpg at 01D27C77.AAD11FB0]

Jesse Teitelbaum | Associate Archivist
Pennsylvania House of Representatives | Archives
469 Forum Building | Harrisburg PA 17120
Phone: 717.783.3866 | Fax: 717.772.1233
Email: jteitelbaum at pabmc.net<mailto:jteitelbaum at pabmc.net>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20170201/d6be76f4/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.jpg
Type: image/jpeg
Size: 31990 bytes
Desc: image001.jpg
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20170201/d6be76f4/attachment.jpg>

More information about the Archivesspace_Users_Group mailing list