[Archivesspace_Users_Group] Archon migration SortOrder values

Flanagan, Patrick PJFlanagan at ship.edu
Mon Jan 11 11:06:56 EST 2016

Hi Chris,

I think I understand. Any rows with identical ParentID and Title would be the problem? I tried:
select Title, ParentID, COUNT(*) FROM tblCollections_Classifications GROUP BY Title, ParentID HAVING count(*) > 1 \G
Empty set (0.02 sec)

... Which I'm fairly certain is correct. (The other query I tried was in tblCollections_Content, which did have many rows come up.)

I'll keep looking for now. Thank you!


From: archivesspace_users_group-bounces at lyralists.lyrasis.org [archivesspace_users_group-bounces at lyralists.lyrasis.org] on behalf of Prom, Christopher John [prom at illinois.edu]
Sent: Monday, January 11, 2016 10:58 AM
To: Archivesspace Users Group
Subject: Re: [Archivesspace_Users_Group] Archon migration SortOrder values


The Archonsort order values are relative to the parent ID-- in other words, not unique.  However, I don’t think that this problem is related to the query you tried to do below, since the issue you are having is with the classifications.  For that reason, you may wish to look for a duplicate parent ID/SortOrder combination in the classification table instead.

It will be a much shorter group of records, so if you can’t find it via a query, you may be able to identify the problem via manual inspection.

Chris Prom

On Jan 11, 2016, at 7:10 AM, Flanagan, Patrick <PJFlanagan at ship.edu<mailto:PJFlanagan at ship.edu>> wrote:

Good morning,

A little while ago I messaged the group about a null pointer exception during migration from Archon -> ArchivesSpace. This question is semi-related to that.

Among the checks to perform before migration is one relating to duplicate SortOrder values in tblCollections_Content. The associated query to perform is: "SELECT ParentID, SortOrder, count(*) from tblCollections_Content Group by ParentID, SortOrder HAVING count(*) > 1;"

I didn't fix that in the current instance I'm migrating because count(*) adds up across 144 rows to be well over 10,000. I'm wondering if that might be the cause of a null pointer exception when attempting to migrate from Archon. A sample of the latest error I've received:

Getting records for: ?p=core/classifications&batch_start=1801
get: https://archon.klnpa.org/psa?p=core/classifications&batch_start=1801
Status code: 200
Status text: Created
response: No matching record(s) found for batch_start=1801
        at org.nyu.edu.dlts.utils.ArchonClient.getRootParent(ArchonClient.java:499)
        at org.nyu.edu.dlts.utils.ArchonClient.getRootParent(ArchonClient.java:520)
        at org.nyu.edu.dlts.utils.ArchonClient.getClassificationRecords(ArchonClient.java:431)
        at org.nyu.edu.dlts.utils.ASpaceCopyUtil.copyClassificationRecords(ASpaceCopyUtil.java:918)
        at org.nyu.edu.dlts.dbCopyFrame$1.run(dbCopyFrame.java:231)
        at java.lang.Thread.run(Thread.java:745)

I was wondering: are the SortOrder values largely arbitrary? If I write up a quick script just to ensure each one has a unique value, would that potentially solve the issue? It's affecting numerous migration attempts. Thank you for your time,

~Patrick Flanagan
KLN Applications Administrator
Keystone Library Network Hub

Archivesspace_Users_Group mailing list
Archivesspace_Users_Group at lyralists.lyrasis.org<mailto:Archivesspace_Users_Group at lyralists.lyrasis.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20160111/d4d1fe90/attachment.html>

More information about the Archivesspace_Users_Group mailing list