[Archivesspace_Users_Group] Transfer failed

Long, Holley W. longh at uncw.edu
Thu Feb 18 16:21:18 EST 2016

Hello All,

My library is migrating one repository in Archon to two repositories in ArchivesSpace. Our plan is to move the Archon repository into ArchivesSpace and then transfer collections to the second repository using ArchivesSpace's transfer functionality. I just tried this out in our test instance and got the following error message. I get the same error regardless of whether the collection has linked agents or not. Has anyone encountered this error or have an idea why it is occurring?

Thanks in advance for your help-

Holley Long

Transfer Failed: {"error":{"linked_agents/0/ref":["Must be one of: JSONModel(:agent_corporate_entity) uri, JSONModel(:agent_family) uri, JSONModel(:agent_person) uri, JSONModel(:agent_software) uri (you provided a String)"]},"warning":null,"invalid_object":"#<JSONModel(:event) {\"linked_agents\"=>[{\"role\"=>\"transmitter\", \"ref\"=>\"/agents/corporate_entities\"}, {\"role\"=>\"recipient\", \"ref\"=>\"/agents/corporate_entities/298\"}], \"linked_records\"=>[{\"role\"=>\"transfer\", \"ref\"=>\"/repositories/3/resources/609\"}], \"event_type\"=>\"custody_transfer\", \"timestamp\"=>\"2016-02-18T20:58:54Z\", \"jsonmodel_type\"=>\"event\", \"external_ids\"=>[], \"external_documents\"=>[]}>"}

Holley Long
Digital Initiatives Librarian
Randall Library, University of North Carolina Wilmington
longh at uncw.edu<mailto:longh at uncw.edu>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20160218/dfcc6485/attachment.html>

More information about the Archivesspace_Users_Group mailing list