[Archivesspace_Users_Group] UPDATE: classification issue

Matthew J Gorzalski mGorzalski at lib.siu.edu
Wed Mar 18 10:51:11 EDT 2015


Then I am not sure how to address our issue.  I planned on deleting the empty classifications in the Aspace admin interface.  But like I said, only 5 classifications were listed instead of the 30 I expected, because 30 appear in the public interface.  And of the listed 5, only University Archives was "correct" in that it had the collections attached to it.  The other classifications were the empty ones, and therefore the correct versions didn't appear in the classification admin interface.

We tried deleted the bad ones from the database end and re-indexing.  It partially worked in that the bad classifications were deleted but the links to those bad classifications still appeared in the ArchivesSpace public view.  Even so, that doesn't address the problem of the bad classifications being migrated to the administrative classification menu while NOT listing the correct ones as well.  If all 30 were listed I could delete the empty ones.


From: archivesspace_users_group-bounces at lyralists.lyrasis.org [mailto:archivesspace_users_group-bounces at lyralists.lyrasis.org] On Behalf Of Prom, Christopher John
Sent: Tuesday, March 17, 2015 4:57 PM
To: Archivesspace Users Group
Subject: Re: [Archivesspace_Users_Group] UPDATE: classification issue

I don't think it will be possible to do your number 1 below and possibly also number 2 would be risky.

The underlying issue here is that the classifications are not scoped to a repository in Archon-there is one classification hierarchy that is shared, whereas in aspace the model is that each repo has its own classification system.

The only way to scope it would be to check empty for a particular classification post migration, then delete them, and we saw that as a risky assumption when designing the migration tools.

Chris Prom

On Mar 17, 2015, at 4:35 PM, Matthew J Gorzalski <mGorzalski at lib.siu.edu<mailto:mGorzalski at lib.siu.edu>> wrote:

When I previously mentioned that only 5 classifications appear in the ASpace classification admin menu instead of the 30 I expected, unfortunately the Manuscripts classification that migrated is one of the empty or "bad" classifications.  See screen shot.  You should see a list of records instead of "no records found" if this was the Manuscripts classification

In other words, the public interface shows 5 manuscript classifications, one of which actually has collections attached to it.  The ASpace admin interface shows only 5 classifications, and the Manuscript classification that happens to be there is one of the empty Manuscript classifications.  In fact, the same goes for our Political Papers and Photographs classifications, and Rare Books classifications.  Only University Archives migrated the correct classification to the ASpace admin classification interface.

Is it possible to rework the migration to: 1) not duplicate classifications per repository, and 2) ensure that the classifications with attached collections are the ones that appear in the ASpace classification administrative menu?

I've typed classification too much.

University Archivist


mgorzalski at lib.siu.edu<mailto:mgorzalski at lib.siu.edu>
P: 618/453-2225
F: 618/453-3440

Archivesspace_Users_Group mailing list
Archivesspace_Users_Group at lyralists.lyrasis.org<mailto:Archivesspace_Users_Group at lyralists.lyrasis.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20150318/ef375287/attachment.html>

More information about the Archivesspace_Users_Group mailing list