[Archivesspace_Users_Group] ead2pdf manual PDF creation?

Galligan, Patrick PGalligan at rockarch.org
Tue Aug 4 12:15:35 EDT 2015

Awesome! Thanks guys, got this running perfectly on our development server.

As always, we'll be updating our github with any code that we produce in case anyone else is interested in automatically generating PDFs in the backend.


Patrick Galligan
Rockefeller Archive Center
Assistant Digital Archivist

From: archivesspace_users_group-bounces at lyralists.lyrasis.org [mailto:archivesspace_users_group-bounces at lyralists.lyrasis.org] On Behalf Of Chris Fitzpatrick
Sent: Tuesday, August 04, 2015 12:00 PM
To: Archivesspace Users Group
Subject: Re: [Archivesspace_Users_Group] ead2pdf manual PDF creation?


Yeah, I just updated the ead2pdf jar, with I think fixes this..

It's here:


Release 0.0.5 * archivesspace/ead2pdf * GitHub
ead2pdf - ASpace EAD2PDF
Read more...<https://github.com/archivesspace/ead2pdf/releases/tag/0.0.5>


Chris Fitzpatrick | Developer, ArchivesSpace
Skype: chrisfitzpat  | Phone: 918.236.6048

From: archivesspace_users_group-bounces at lyralists.lyrasis.org<mailto:archivesspace_users_group-bounces at lyralists.lyrasis.org> <archivesspace_users_group-bounces at lyralists.lyrasis.org<mailto:archivesspace_users_group-bounces at lyralists.lyrasis.org>> on behalf of Steven Majewski <sdm7g at virginia.edu<mailto:sdm7g at virginia.edu>>
Sent: Tuesday, August 4, 2015 5:51 PM
To: Archivesspace Users Group
Subject: Re: [Archivesspace_Users_Group] ead2pdf manual PDF creation?

I ran the conversion on a random exported EAD file and got the same error.
The rest of the message shows it couldn't find as-helper-functions.xsl

work$ java -jar  ../ead2pdf/ead2pdf.jar prod/local-exp/22-MSS12838.xml  22.pdf
Error at /xsl:stylesheet/xsl:include[1]
  XTSE0165: I/O error reported by XML parser processing
  /projects/Archivespace/work/lib/as-helper-functions.xsl (No such file or directory)
NoMethodError: undefined method `rewind' for nil:NilClass

It looks like there's a path dependency on finding that file:

ead2pdf$ ack as-helper-functions
24:    <xsl:include href="./lib/as-helper-functions.xsl"/>

36:   # @xslt.gsub!('<xsl:include href="as-helper-functions.xsl"/>', "<xsl:include href='#{File.join(File.dirname(__FILE__), '../lib', 'as-helper-functions.xsl')}'/>" )

When I cd into the ead2pdf directory and run the same transform, it runs without error.

[ file path is:  ead2pdf/lib/as-helper-functions.xsl ]

- Steve.

On Aug 3, 2015, at 11:38 AM, Galligan, Patrick <PGalligan at rockarch.org<mailto:PGalligan at rockarch.org>> wrote:


We're trying to set up a workflow where we automatically generate PDF copies of finding aids from our EAD. Rather than set up two API calls (one to export updated EAD and one to download updated PDF), we wanted to use the ead2pdf.jar to run through and create PDF files.

However, when trying to run it from our dev server, I'm getting the following error:

NoMethodError: undefined method `rewind' for nil:NilClass

Any idea what could be causing that?

Patrick Galligan
Rockefeller Archive Center
Assistant Digital Archivist

Archivesspace_Users_Group mailing list
Archivesspace_Users_Group at lyralists.lyrasis.org<mailto:Archivesspace_Users_Group at lyralists.lyrasis.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20150804/c961cb7d/attachment.html>

More information about the Archivesspace_Users_Group mailing list