[Archivesspace_Users_Group] ead2pdf manual PDF creation?

Steven Majewski sdm7g at virginia.edu
Tue Aug 4 11:51:44 EDT 2015

I ran the conversion on a random exported EAD file and got the same error. 
The rest of the message shows it couldn’t find as-helper-functions.xsl 

work$ java -jar  ../ead2pdf/ead2pdf.jar prod/local-exp/22-MSS12838.xml  22.pdf
Error at /xsl:stylesheet/xsl:include[1] 
  XTSE0165: I/O error reported by XML parser processing
  /projects/Archivespace/work/lib/as-helper-functions.xsl (No such file or directory)
NoMethodError: undefined method `rewind' for nil:NilClass

It looks like there’s a path dependency on finding that file:

ead2pdf$ ack as-helper-functions
24:    <xsl:include href="./lib/as-helper-functions.xsl"/>  

36:   # @xslt.gsub!('<xsl:include href="as-helper-functions.xsl"/>', "<xsl:include href='#{File.join(File.dirname(__FILE__), '../lib', 'as-helper-functions.xsl')}'/>" ) 

When I cd into the ead2pdf directory and run the same transform, it runs without error. 

[ file path is:  ead2pdf/lib/as-helper-functions.xsl ] 

— Steve. 

> On Aug 3, 2015, at 11:38 AM, Galligan, Patrick <PGalligan at rockarch.org> wrote:
> Hey,
> We’re trying to set up a workflow where we automatically generate PDF copies of finding aids from our EAD. Rather than set up two API calls (one to export updated EAD and one to download updated PDF), we wanted to use the ead2pdf.jar to run through and create PDF files.
> However, when trying to run it from our dev server, I’m getting the following error:
> NoMethodError: undefined method `rewind' for nil:NilClass
> Any idea what could be causing that?
> Patrick Galligan
> Rockefeller Archive Center
> Assistant Digital Archivist
> 914-366-6386
> _______________________________________________
> Archivesspace_Users_Group mailing list
> Archivesspace_Users_Group at lyralists.lyrasis.org <mailto:Archivesspace_Users_Group at lyralists.lyrasis.org>
> http://lyralists.lyrasis.org/mailman/listinfo/archivesspace_users_group <http://lyralists.lyrasis.org/mailman/listinfo/archivesspace_users_group>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20150804/0b3b85df/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 4943 bytes
Desc: not available
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20150804/0b3b85df/attachment.bin>

More information about the Archivesspace_Users_Group mailing list