[Archivesspace_Users_Group] Can't delete guide under mysql: foreign key constraint.

Steven Majewski sdm7g at virginia.edu
Mon Mar 10 16:55:00 EDT 2014

With ArchivesSpace using mysql, I Imported an EAD guide and then tried to delete it. 

If I try to delete the collection from the View of Edit page, I get:

We're sorry, but something went wrong.

If I try to delete my checking it in the browse page and clicking delete, I get:

Unable to delete records:
["{\"error\":\"Record deletion failed: Java::ComMysqlJdbcExceptionsJdbc4::MySQLIntegrityConstraintViolationException: Cannot delete or update a parent row: a foreign key constraint fails (`archivesspace/archival_object`, CONSTRAINT `archival_object_ibfk_5` FOREIGN KEY (`parent_id`) REFERENCES `archival_object` (`id`))\"}\n"] [/repositories/2/resources/3719]

I was finally able to delete the collection only after individually deleting all of it’s components. 

I tried with another install of on my laptop, using the development db instead of mysql.
I imported EAD and then deleted the top level collection with no problem. 
Then I reconfigured it to use mysql, and I get the same errors as above. 

— Steve Majewski

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20140310/cc67d027/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 4943 bytes
Desc: not available
URL: <http://lyralists.lyrasis.org/pipermail/archivesspace_users_group/attachments/20140310/cc67d027/attachment.bin>

More information about the Archivesspace_Users_Group mailing list